Bug 135514 - db4-util documentation has incorrect links
db4-util documentation has incorrect links
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: db4 (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Jindrich Novy
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 04:35 EDT by Göran Uddeborg
Modified: 2013-07-02 19:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-08 17:55:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2004-10-13 04:35:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.4.3)
Gecko/20040924

Description of problem:
The db4-utils index.html file refers back to the documentation
directory for the db4 base package.  But the files it refers are also
in the utils documentation directory.

Version-Release number of selected component (if applicable):
db4-utils-4.1.25-8

How reproducible:
Always

Steps to Reproduce:
1.Open /usr/share/doc/db4-utils-4.1.25/utility/index.html in mozilla
2.Click on the "db_archive" link.

Actual Results:  Error message that
file:///usr/share/doc/db4-4.1.25/utility/db_archive.html cannot be found.

Expected Results:  The documentation page for db_archive.

Additional info:

The correct link would be
file:///usr/share/doc/db4-utils-4.1.25/utility/db_archive.html
Comment 1 Jeff Johnson 2004-11-14 01:16:16 EST
Fixed in db4-4.1.25-9 when built for RHEL3. Thanks for noticing.
Comment 2 Radek Bíba 2005-05-04 10:54:36 EDT
This problem has been fixed but there are actually more similar bugs.
/usr/share/doc/db4-devel-4.1.25/index.html (from db4-devel) has links:

../db4-devel-4.1.25/api_java/c_index.html
-- should be ../db4-java-4.1.25/api_java/c_index.html

../db4-devel-4.1.25/api_java/java_pindex.html
-- should be ../db4-java-4.1.25/api_java/java_pindex.html

reftoc.html
-- doesn't exist at all. I searched a little at sleepycat.com and found a
ref/toc.html file which should be /usr/share/doc/db4-devel-4.1.25/ref/toc.html.
I say, 'should be', it isn't there but the links on the on-line page point to
files with names exactly like those files in /usr/share/doc/db4-devel-4.1.25/ref
subtrees.

Link to this file (reftoc.html) is also present on each of
/usr/share/doc/db4-utils-4.1.25/utility/*, except for index.html.

Plus, the db4-java package contains the same problem as db4-utils. It has kind
of weird links like

a href="../../db4-devel-4.1.25/api_java/env_close.html"

which doesn't point to an existing file. Instead of db4-devel-4.1.25 there
should be db4-java-4.1.25. Or better, since all the files are in one directory,
the links could be like

a href="env_close.html"

These bad links, and also the reftoc.html issue, are present in
/usr/share/doc/db4-java-4.1.25/api_java/* . There may be even more bad links,
better try some link-checker.

Note You need to log in before you can comment on or make changes to this bug.