Bug 135517 - ooffice crash when opening certain .xls files
ooffice crash when opening certain .xls files
Status: CLOSED DUPLICATE of bug 137281
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 04:53 EDT by David Fraser
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-02 13:40:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stack trace from application crash (5.52 KB, text/plain)
2004-10-13 05:04 EDT, David Fraser
no flags Details

  None (edit)
Description David Fraser 2004-10-13 04:53:02 EDT
Description of problem:
OpenOffice.org crashes if I open certain .xls files (from a phone
billing application)
This one is strange because it only happens if I open two of the files
or close one and reopen it.
Also, bug-buddy comes up but fails to generate a stack trace.
The resulting soffice.bin process doesn't die unless I kill -9 it.
Sometimes that doesn't even work and then kill -18 seems to work.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-9

How reproducible:
Consistently

Steps to Reproduce:
1. start openoffice.org
2. open one spreadsheet from the given list
3. open another spreadsheet from the given list
  
Actual results:

Application crashes. Messages are as follows:
  Main memory shortage. Please quit some applications or close some
windows before continuing.
  An unrecoverable error has occured. All modified files have been
saved and can probably be recovered at program restart.
  An unrecoverable error has occured. All modified files have been
saved and can probably be recovered at program restart.

Expected results:

Not crashing

Additional info:

I have tested this with other builds of openoffice.org on Linux
(non-Fedora builds):
OpenOffice.org 1.1.0 (official build from openoffice.org)
OpenOffice.org 1.1.3 (built from source)
Neither of them display the bug, so it seems to be related to the
Fedora build

I don't particularly want to upload my financial documents to a public
web server, thats why I haven't attached them.
Comment 1 David Fraser 2004-10-13 04:55:31 EDT
By the way, bug buddy kindly reported this to the ximian bug database:
http://bugzilla.ximian.com/show_bug.cgi?id=68129
Comment 2 David Fraser 2004-10-13 04:59:52 EDT
I have tested and resaving the files as .xls from the working version
of openoffice (1.1.3) means that they can open fine in the fedora
version without this bug. That seems like it must be something in the
file parsing then...
Comment 3 David Fraser 2004-10-13 05:04:11 EDT
Created attachment 105126 [details]
stack trace from application crash

Finally managed to get a stack trace on the command line, not quite sure how.
But this looks like it may contain the relevant info:
/usr/lib/ooo-1.1/program/libsfx645li.so(_Z18SfxNewHandler_Implv+0x60)[0xf20cae9a]

/usr/lib/ooo-1.1/program/soffice.bin[0x8086833]
/usr/lib/ooo-1.1/program/soffice.bin(_Znaj+0x2f)[0x80869c5]
/usr/lib/ooo-1.1/program/libsfx645li.so(_ZN17SfxPSSection_Impl4LoadER8SvStream+0x88)[0xf1f25506]

/usr/lib/ooo-1.1/program/libsfx645li.so(_ZN10SfxPS_Impl4LoadER8SvStream+0xbe)[0xf1f2544a]

/usr/lib/ooo-1.1/program/libsfx645li.so(_ZN15SfxDocumentInfo15LoadPropertySetEP9SvStorage+0x14d)[0xf1f267b5]


I can send the actual files that cause the crash by private mail if that would
help
Comment 4 Caolan McNamara 2004-11-02 13:39:25 EST
This has got to be the same as #137281# as its got the same stack. The
patch there (coming in 1.1.2-11) will surely fix this. 

*** This bug has been marked as a duplicate of 137281 ***
Comment 5 Caolan McNamara 2004-11-02 13:40:30 EST
closing as duplicate, if I'm wrong reopen post testing forthcoming
version 1.1.2-11.
Comment 6 David Fraser 2004-11-12 01:01:47 EST
Have tested and works great now, thanks Caolan :-)

Note You need to log in before you can comment on or make changes to this bug.