Bug 135527 - Disks aren't detected in a Dell PowerEdge 750 with 2 sata disks in RAID-1 (Dell CERC RAID controller)
Disks aren't detected in a Dell PowerEdge 750 with 2 sata disks in RAID-1 (De...
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tom Coughlan
:
Depends On: 132021
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 06:11 EDT by Paulo Sousa
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 07:02:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paulo Sousa 2004-10-13 06:11:03 EDT
Description of problem:

I'm trying to install Red Hat Enterprise Linux 4 beta 1 in a Dell 
PowerEdge 750 equipped with 2 SATA harddisks with 250GB operating in 
RAID-1 (Dell CERC RAID controller).

After pressing OK in the screen "Select the appropriate keyboard for 
the system", a popup box appears with the title "Error" and 
saying "Error opening /dev/sda: No such adevice or address". When I 
hit "Retry" nothing happens and when I hit "Cancel" the installation 
proceeds but then when I try to create partitions the same error box 
appears.

I already managed to install Windows 2000 in the same machine only to 
check if there was any problem with the disk/RAID configuration.

Version-Release number of selected component (if applicable):


How reproducible:

I already tried in another PowerEdge 750 with the same disk 
configuration and the same problem happenned. So, it suffices to try 
to install Red Hat Enterprise Linux 4 beta 1 in any PowerEdge 750 
with the same configuration.

Steps to Reproduce:
1. Insert Red Hat CD 1
2. Follow setup normal steps
3.
  
Actual results:

After pressing OK in the screen "Select the appropriate keyboard for 
the system", a popup box appears with the title "Error" and 
saying "Error opening /dev/sda: No such adevice or address". When I 
hit "Retry" nothing happens and when I hit "Cancel" the installation 
proceeds but then when I try to create partitions the same error box 
appears.


Expected results:

System being installed without problems.

Additional info:
Comment 1 Paulo Sousa 2004-10-13 10:56:29 EDT
Also managed to install Whitebox Enterprise Edition 3.0 respin 1 in 
the same machine without any problem.
Comment 2 Bill Nottingham 2004-10-13 16:11:41 EDT

*** This bug has been marked as a duplicate of 135484 ***
Comment 3 Bill Nottingham 2004-10-13 16:13:08 EDT
Whoops, that should just be 'see also bug 135484'.
Comment 5 Paulo Sousa 2004-10-13 17:04:52 EDT
I think it's not exactly the same bug, because Fedora 2 also shows me 
the same error.
Comment 6 John A. Hull 2004-10-15 11:48:06 EDT
This bug is related to an Adaptec (aacraid) card. 135484 is a megaraid
card...
Comment 10 David Wilson 2004-11-23 20:41:51 EST
And Fedora Core 3 cannot be installed on this platform.

After the keyboard selection screen, a error dialog box with "Error
opening /dev/sda: No such device or address" appears. Just like RHEL4
above.

Dell PE750 (A02 BIOS) with Dell CERC 1.5/6ch SATA RAID 1 card (v4.1-0
firmware) using aacraid driver.

Ctrl-Alt-F2 at Welcome to Fedora screen allows me to see the following:

# grep aacraid /proc/modules
aacraid 45809 1 - Live 0xe0909000
scsi_mod 119313 4 libata,aacraid,sr_mod,sd_mod, Live 0xe0958000
# cat /proc/partitions
major minor #blocks name
7     0     72820   loop0
8     0   78091136  sda
8     1     56196   sda1
# fdisk -l
<no output>

Any reference to /dev/sda or /dev/sda1 results in "No such device or
address" error.
Comment 11 David Wilson 2004-11-24 23:16:32 EST
I have successfully installed FC2 on my PE750. This is with the
default 2.6.5 kernel FC2 shipped with. If I try and run 2.6.8 or 2.6.9
kernels from the FC2 updates the system locks up with a siren on the
CERC board sounding continously.

The non-working kernels are kernel-smp-2.6.8-1.521.i686 and
kernel-smp-2.6.9-1.6_FC2.i686.

The CERC card behaves differently depending on its state
(Building/Verifying or Optimal). In the B/V state drive access from
new kernels just fail. In Optimal state the siren sounds...
Comment 14 Tom Coughlan 2004-12-10 09:11:03 EST
The fix for this bug is posted here:

http://marc.theaimsgroup.com/?l=linux-scsi&m=110252243627410&w=2

This patch was checked in to RHEL 4 RC and FC3 last night. This BZ has been set
to modified.
Comment 15 Jay Turner 2005-01-14 07:02:21 EST
Patch confirmed in latest kernels, so closing this out.  Please reopen if the
problem still occurs with most recent code.
Comment 16 Brad Kramer 2005-01-24 16:15:11 EST
I have just downloaded the latest, and the problems persist... I am 
still looking for a solution... I will post back if I find something.
Comment 17 Brad Kramer 2005-01-24 16:17:39 EST
actually, If I were to read all the comments, I would see that there 
is a patch... sorry about that...

Note You need to log in before you can comment on or make changes to this bug.