Bug 135528 - Character display corrupts under flashing cursor
Character display corrupts under flashing cursor
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 06:48 EDT by David Wood
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-18 05:50:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Wood 2004-10-13 06:48:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041012
Firefox/0.10.1

Description of problem:
Editing a file using gvim, displayed with Luxi Mono 9 or smaller, on a
1280 x 1024 screen resolution, the character under the flashing cursor
becomes corrupted while highlighted.  Changing to Luxi Mono 10 or
larger solves the problem.

Version-Release number of selected component (if applicable):
vim-X11 1:6.3.030-1

How reproducible:
Always

Steps to Reproduce:
1. Start gvim with Luxi Mono 9
2. Position the cursor over a character (ie. ! or p)

    

Actual Results:  With a highlighted 'p' the character is replaced by a
black square, alternating with the black cursor rectangle.
With a hightlight '!' the character is replaced by a black vertical
line alternating with the black cursor rectangle.

Expected Results:  Normal character displayed

Additional info:

I don't believe I saw this under the fc3test2 release.
Comment 1 Karsten Hopp 2004-10-13 07:44:37 EDT
I cannot reproduce this here with a system updated to the latest 
packages. What is your LANG environment set to ? And do you have 
the latest pango/Xorg packages installed ? 
Comment 2 David Wood 2004-10-13 10:20:28 EDT
pango 1.6.0-3     xorg-x11 6.8.1-4     LANG=en_GB.UTF-8
Reproducibility appears weirder than I originally thought!
My .gvimrc file has this ...
set gfn=Luxi\ Mono\ 9
set lines=45
set columns=140
set bk
set bdir=.
set shiftwidth=3
syntax enable

Try typing a row of ssssssssssssssssssss  and then highlight some of
the characters backwards along the line to shade them grey.  I'm
seeing some of the letters replaced with black squares.  Even a letter
to the right of where I start highlighting can turn into a black
square.  However, partially sliding the gvim window off the screen and
back again refreshes the characters and grey shading perfectly again.
Comment 3 Karsten Hopp 2004-10-18 05:50:42 EDT
I still can't reproduce this with exactly the same packageversions 
and your .gvimrc. This very much looks like a problem with your 
setup, either the graphics hardware (it would show in other 
applications, too) or software. 

Note You need to log in before you can comment on or make changes to this bug.