Bug 135536 - compat-glibc++ for s390x (64Bit) missing
compat-glibc++ for s390x (64Bit) missing
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: IBMJava2-SDK (Show other bugs)
3.0
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Karen Bennet
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 07:34 EDT by Falko Pilz
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 11:54:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Falko Pilz 2004-10-13 07:34:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
Hello,

I would use IBM-Java-142 for 64bit s390x Linux.
At Installation I selected "Compatibility Arch Development Support"
completely.
But if I start java -verbose -version it says /usr/lib64/libstdc++...
not found and (jitc disabled). So Java run in interpreter modus which
is much slower then java himself. If bits by java are skulking at this
java they should have tea time :-)

Because of that I know Java request this lib, I run rpm -qa| grep
libstdc++ and the pakage was there without any clue to 31 bit. 
So I requested rpm -ql libstdc++ and it says okay it is in /usr/lib
instead of /usr/lib64. So I found 2 rpms on the CD one for s390 and
one for s390x. 
Because that I install s390x the s90x package should be installed also
but only the s390 one was it.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Expected Results:  "Compatibility Arch Development Support" should be
a little bit more "Arch" sensitive :-)

Additional info:

related on both IBMJava2-SDK-1.42-s390x and compat-glibc, but bug
between RPMS couldn't be summited in a different manner.
Comment 1 Mike Gahagan 2005-03-02 11:54:37 EST
There is no "compat-glibc++" package, however we do have
compat-libstdc++-7.2-2.95.3.80.s390x is in the U4 zseries tree. This should give
you the c++ support you need. 

Comment 2 Falko Pilz 2005-03-03 01:38:19 EST
hello,

you're false, the package is still in the RHEL3 s390x but it isn't a member of
the anaconda selektion "Compatibility Arch Development Support".
That was the matter.

Regards

Falko

Note You need to log in before you can comment on or make changes to this bug.