Bug 13555 - Xwrapper won't start
Summary: Xwrapper won't start
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-06 23:07 UTC by hugh.mcdonald
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-06 23:07:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description hugh.mcdonald 2000-07-06 23:07:49 UTC
RH 6.0 workstation installation:  X with gdm etc. has been running
normally for over a year.  Overnight, the X server (XF86_SVGA) died,
cause unknown.  Now Xwrapper uses 98.3% of the CPU time without
any output (without starting XF86_SVGA).  I can manually start
XF86_SVGA (as root, or after chmod u+s XF86_SVGA, as a normal
user), and then I can start the window manager, etc., and use the
machine.

It appears that some file was left in a bad state (missing, wrong
permissions, ...) when the X-server died, but since man gdm and man
Xwrapper are equally helpful, I have no idea where to start looking.  It
would be most helpful if there were some documentation listing ALL
the files used/checked/created by Xwrapper/gdm/gdmgreeter/etc., and
what their contents and permissions should be.  I have had similar
problems on other machines, and I have had to re-install the X-
windows system just as if I were using Windows98.  The
current setup is just too brittle.

Comment 1 Preston Brown 2000-08-29 18:35:10 UTC
remove /tmp/.X11-unix and start again.


Note You need to log in before you can comment on or make changes to this bug.