Bug 135555 - Fetchmail hangs the system partially
Fetchmail hangs the system partially
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fetchmail (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 10:34 EDT by Viet Yen Nguyen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-25 07:24:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A strace of the fetchmail process (13.72 KB, text/plain)
2004-10-13 10:35 EDT, Viet Yen Nguyen
no flags Details
The used fetchmailrc (865 bytes, text/plain)
2004-10-13 10:37 EDT, Viet Yen Nguyen
no flags Details

  None (edit)
Description Viet Yen Nguyen 2004-10-13 10:34:16 EDT
Description of problem:

When running fetchmail, the system hangs partially. 

First, fetchmail hangs and it doesn't get killed, neither by root and
kill -9, it only dies on reboot, but it does cause the filesystem not
to umount cleanly. 

Secondly, according to a strace I did, it hangs on creating the
.fetchmail.pid. If I try to remove .fetchmail.pid during a stale
fetchmail, the rm .fetchmail.pid also hangs and it won't get killed
either. Then everything that concerns .fetchmail.pid hangs. The only
solution is a reboot.

Thirdly, when it all happens, the system load is staying high, always
above 1.00.

Version-Release number of selected component (if applicable):

vietyen@oxygen:~% fetchmail --version
This is fetchmail release 6.2.5+IMAP-GSS+RPA+NTLM+SDPS+SSL+INET6+NLS
Fallback MDA: (none)
Linux oxygen 2.6.8-1.541 #1 Wed Sep 1 18:01:20 EDT 2004 i686 athlon
i386 GNU/Linux
Taking options from command line and /home/vietyen/.fetchmailrc
Idfile is /home/vietyen/.fetchids
Progress messages will be logged via syslog
Fetchmail will show progress dots even in logfiles.
Fetchmail will forward misaddressed multidrop messages to vietyen.
Options for retrieving from nguyen@imap.cs.utwente.nl:
  True name of server is imap.cs.utwente.nl.
  Protocol is IMAP.
  All available authentication methods will be tried.
  Server nonresponse timeout is 300 seconds (default).
  Default mailbox selected.
  Only new messages will be retrieved (--all off).
  Fetched messages will not be kept on the server (--keep off).
  Old messages will not be flushed before message retrieval (--flush off).
  Rewrite of server-local addresses is enabled (--norewrite off).
  Carriage-return stripping is enabled (stripcr on).
  Carriage-return forcing is disabled (forcecr off).
  Interpretation of Content-Transfer-Encoding is enabled (pass8bits off).
  MIME decoding is disabled (mimedecode off).
  Idle after poll is disabled (idle off).
  Nonempty Status lines will be kept (dropstatus off)
  Delivered-To lines will be kept (dropdelivered off)
  Fetch message size limit is 100 (--fetchsizelimit 100).
  Do binary search of UIDs during 9 out of 10 polls (--fastuidl 10).
  Messages will be delivered with "/usr/bin/maildrop".
  Single-drop mode: 1 local name(s) recognized.
  No UIDs saved from this host.

How reproducible:

Run fetchmail as an user and watch it die.

Steps to Reproduce:
1. Create a simple configuration in .fetchmailrc
2. Run fetchmail -a
3. And watch
  
Actual results:

Fetchmail hangs and causes a heavy load on the system.

Expected results:

Downloading my email nicely from the IMAP server.

Additional info:

I upgraded my FC2 to FC3T3 by a harddrive install from the DVD iso.
Comment 1 Viet Yen Nguyen 2004-10-13 10:35:04 EDT
Created attachment 105144 [details]
A strace of the fetchmail process
Comment 2 Viet Yen Nguyen 2004-10-13 10:37:08 EDT
Created attachment 105145 [details]
The used fetchmailrc
Comment 3 Bill Nottingham 2004-10-13 16:45:01 EDT
Is your homedir on a local filesystem?
Comment 4 Viet Yen Nguyen 2004-10-13 17:12:55 EDT
Yes, it is:

vietyen@oxygen:~% mount
/dev/hda3 on / type xfs (rw)
/dev/hda5 on /home type xfs (rw)
...

I still find it very odd, especially if you see the strace that the
last write system call is not finished. 

SELinux is also off by default on boot with selinux=0, and this is
confirmed with dmesg | grep SE:
vietyen@oxygen:~% dmesg | grep SE
SELinux:  Disabled at boot.

Comment 5 Michael Schwendt 2004-10-18 03:39:37 EDT
It's certainly not fetchmail as included with FC3T3 (works fine for me
and can't reproduce this at all), but much more likely related to the
used XFS. An important configuration detail which should have been
mentioned in the original bug report.
Comment 6 Viet Yen Nguyen 2004-10-18 04:09:34 EDT
I am still using the same kernel I used in FC2:
Linux oxygen 2.6.8-1.541 #1 Wed Sep 1 18:01:20 EDT 2004 i686 athlon
i386 GNU/Linux

And fetchmail did work fine in FC2 (with that kernel and with XFS)

I still haven't upgraded the kernel to a newer version because of the
problems that are known with the NVIDIA drivers.

I don't which leftover from the FC2 upgrade is still bugging me with
this, although I believe without much doubt that this problem does not
occur with fresh FC3 installs
Comment 7 Viet Yen Nguyen 2004-10-18 12:53:49 EDT
I just fetched the sources from the Fetchmail homepage and compiled it
myself. The resulting binary also hangs. 

Well, my knowledge of system calls is limited, but perhaps glibc is
doing something nasty, as the kernel is still the old one I used with FC2.
Comment 8 Viet Yen Nguyen 2004-10-25 07:25:28 EDT
Fetchmail seems to work with kernel Linux oxygen 2.6.9-1.640 #1 Wed
Oct 20 09:55:51 EDT 2004 i686 athlon i386 GNU/Linux

This kernel package comes from FC3 RC1, which I upgraded to.

Note You need to log in before you can comment on or make changes to this bug.