Bug 1355665 - Suggest to limit the burst value to be not less than the throttle value
Summary: Suggest to limit the burst value to be not less than the throttle value
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Stefan Hajnoczi
QA Contact: Gu Nini
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 07:58 UTC by Gu Nini
Modified: 2016-11-07 21:23 UTC (History)
14 users (show)

Fixed In Version: qemu-kvm-rhev-2.6.0-20.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 21:23:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
Test_shell_script_with_FIO (1.45 KB, text/plain)
2016-07-12 07:58 UTC, Gu Nini
no flags Details
Test log for bps=512000 bps_max=51200 throttling.bps-total-max-length=1 (15.45 KB, text/plain)
2016-07-12 08:01 UTC, Gu Nini
no flags Details
Test log for bps=512000 bps_max=51200 throttling.bps-total-max-length=2 (15.32 KB, text/plain)
2016-07-12 08:02 UTC, Gu Nini
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description Gu Nini 2016-07-12 07:58:50 UTC
Created attachment 1178802 [details]
Test_shell_script_with_FIO

Description of problem:
Currently, for qemu iothrottling, the burst value could be set smaller than the throttle vaule(i.e. the FOO_max value could be smaller than the FOO value), which makes the burst is meaningless, so suggest to limit its value to be equal or larger than throttle value.

After some test by setting the burst value smaller than the throttle value, it's found: If set burst_length at the same time, the IO would be limited only by the burst value; and if not set burst_length, the IO is limited by the throttle value. Please refer to attached script/test logs for details of current issue.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Gu Nini 2016-07-12 08:01:41 UTC
Created attachment 1178803 [details]
Test log for bps=512000 bps_max=51200 throttling.bps-total-max-length=1

Comment 2 Gu Nini 2016-07-12 08:02:28 UTC
Created attachment 1178804 [details]
Test log for bps=512000 bps_max=51200 throttling.bps-total-max-length=2

Comment 4 Alberto Garcia 2016-07-26 12:36:33 UTC
(In reply to Gu Nini from comment #0)
> Currently, for qemu iothrottling, the burst value could be set
> smaller than the throttle vaule(i.e. the FOO_max value could be
> smaller than the FOO value), which makes the burst is meaningless,
> so suggest to limit its value to be equal or larger than throttle
> value.

I think I didn't restrict that when I wrote this feature because I
assumed no one would define a FOO_max level that is lower than FOO.
One could argue that if the user does that on purpose then they
deserve the outcome :-)

But I guess it's fine to forbit that kind of setup altogether (that
is, adding a new check to throttle_is_valid()).

The only thing we need to be careful with is that we must not call
throttle_is_valid() after throttle_config(), because the latter sets
FOO_max = FOO / 10 if FOO_max is not set (see throttle_fix_bucket()
for details).

But that doesn't seem to be happening so we should be safe.

Comment 5 Miroslav Rezanina 2016-08-10 18:55:07 UTC
Fix included in qemu-kvm-rhev-2.6.0-20.el7

Comment 7 Gu Nini 2016-08-16 06:33:35 UTC
Verify the bug on following sw versions:

Host kernel: 3.10.0-489.el7.x86_64
Qemu-kvm-rhev: qemu-kvm-rhev-2.6.0-20.el7.x86_64


Now there is prompt "bps_max/iops_max cannot be lower than bps/iops" if setting burst value less than throttle value.

Comment 9 errata-xmlrpc 2016-11-07 21:23:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.