Bug 135568 - thunderbird exits if java plugin is installed in $HOME/.mozilla/plugins
thunderbird exits if java plugin is installed in $HOME/.mozilla/plugins
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-10-13 11:37 EDT by Thomas Woerner
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 02:57:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 223600 None None None Never

  None (edit)
Description Thomas Woerner 2004-10-13 11:37:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041012
Firefox/0.10.1

Description of problem:
thunderbird crashes if java plugin is installes in
$HOME/.mozilla/plugins and you try to write a new email.

Version-Release number of selected component (if applicable):
thunderbird-0.8.0-6

How reproducible:
Always

Steps to Reproduce:
1. Install Java JRE/SDK (e.g. j2sdk1.4.2_05).
2. Link the plugin (libjavaplugin_oji.so) to $HOME/.mozilla/plugins.
3. Start thunderbird and try to write an email, either a new one or a 
   reply.


Actual Results:  Thunderbird crashes.

Expected Results:  Opened email dialog.

Additional info:
Comment 1 Thomas Woerner 2004-10-13 12:29:24 EDT
This is no browser crash, it is an exit. gdb reports this:

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -151137632 (LWP 15947)]
[New Thread -153261136 (LWP 15950)]
[New Thread 87313328 (LWP 15951)]
[New Thread 27528112 (LWP 15952)]
[New Thread 111774640 (LWP 15953)]
Detaching after fork from child process 15954.
[New Thread -166233168 (LWP 15955)]
[Thread 111774640 (LWP 15953) exited]
INTERNAL ERROR on Browser End: Could not get the JVM manager
System error?:: Success

Program exited with code 0377.
/tmp/gdb.run:2: Error in sourced command file:
No stack.
Comment 2 Christopher Aillon 2004-10-13 12:41:55 EDT
It looks like this is https://bugzilla.mozilla.org/show_bug.cgi?id=223600
Comment 3 Christopher Aillon 2004-11-25 02:57:08 EST
Fixed upstream in 0.9, which is now in rawhide.

Note You need to log in before you can comment on or make changes to this bug.