Bug 135570 - panel freezes when loading user from nfs mounted home directory
panel freezes when loading user from nfs mounted home directory
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 11:49 EDT by Dmitry Savransky
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 11:11:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome panel debug log (146 bytes, text/plain)
2004-11-05 10:47 EST, Dmitry Savransky
no flags Details
strace output (807.11 KB, text/plain)
2004-11-17 11:25 EST, Dmitry Savransky
no flags Details
strace output (714.20 KB, text/plain)
2004-11-17 11:26 EST, Dmitry Savransky
no flags Details

  None (edit)
Description Dmitry Savransky 2004-10-13 11:49:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10.1

Description of problem:
     I have two computers both running fc2 (same kernel version, same
software, everthying replicated exactly the same, but with slightly
differing hardware).  Both computers have the same users (with the
same uids and settings) and the home directories are mounted on one of
the computers on an nfs share.
     Whenever a user logs into the computer where the home directories
are mounted as nfs, the panel initially freezes for up to one minute.
 If left alone, it will eventually unfreeze and everything will work
okay, but if any other actions are attempted while it is frozen, it
will usually crash and dump the core.
     No such problems occur on the other computer where the home
directories are on the native disk.
    I have attempted to delete all gnome configuration file from a
user directory, and have created a completely new user from the second
computer - neither action made any difference.  If a user's home
directory is changed to one on the local filesystem on the second
computer, problem does not occur.

Version-Release number of selected component (if applicable):
gnome-panel-2.6.0-9

How reproducible:
Always

Steps to Reproduce:
1.Set up two computers with the same users.
2.Mount home directory from one computer as nfs share on second computer.
3.Log in as any user on second computer
    

Actual Results:  Panel freezes (i.e. does not respond to any user
actions) for up to one minute.

Expected Results:  Panel should behave normally.

Additional info:
Comment 1 Dmitry Savransky 2004-10-18 11:22:54 EDT
I have recently noticed that a simillar freeze/delay occurs when I
launch Adobe Acrobat.  I'm guessing that this happens because Acrobat
reads a preference file from the home directory mounted from the other
computer, but, oddly enough, other programs which also read info from
the home directory (such as firefox) do not exhibit this delay.
ds
Comment 2 Mark McLoughlin 2004-10-28 09:34:07 EDT
We'll need some more debugging info to have any hope of figuring this out.

Try this:

 1) gnome-session-remove gnome-panel

 2) GNOME_PANEL_DEBUG=1 gnome-panel

Do you see the freeze then? If so then try doing "GNOME_PANEL_DEBUG=1
strace -ttt gnome-panel 2>t.log" and attaching the output here.
Comment 3 Dmitry Savransky 2004-11-05 10:47:45 EST
Created attachment 106220 [details]
gnome panel debug log

output from GNOME_PANEL_DEBUG=1 strace -ttt gnome-panel 2>t.log
Comment 4 Mark McLoughlin 2004-11-12 12:15:18 EST
Dmitry: an strace log should show a lot more detail than that, not
sure what you did wrong

e.g. do "strace -ttt ls" and see the spew it gives
Comment 5 Dmitry Savransky 2004-11-17 11:25:15 EST
Created attachment 106894 [details]
strace output

part 1/2
Comment 6 Dmitry Savransky 2004-11-17 11:26:05 EST
Created attachment 106895 [details]
strace output

part 2/2
Comment 7 Mark McLoughlin 2004-11-17 12:40:31 EST
Well, here's the problem:

1100548226.348258 open("/home/ds264/.recently-used", O_RDWR) = 27
1100548226.349492 fstat64(27, {st_mode=S_IFREG|0644, st_size=2773,
...}) = 0
1100548226.349727 mmap2(NULL, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xf61d4000
1100548226.349835 _llseek(27, 0, [0], SEEK_SET) = 0
1100548226.349940 fcntl64(27, F_SETLK, {type=F_WRLCK, whence=SEEK_CUR,
start=0, len=0}) = -1 EIO (Input/output error)
1100548286.392856 write(2, "\n** (gnome-panel:4330): WARNING "..., 72


Its trying to lock ~/.recently used and timing out after one minute.

Do you have the nfslock service running on both machines? Look in
system-config-services?

Please let me know if that fixes the problem. Thanks.
Comment 8 Dmitry Savransky 2004-11-29 11:11:18 EST
Hi,
   You were absolutely correct - nfslock was running on both machines,
but, unlike nfs and rquotad, nlockmgr was not using the port I left
open for it in both firewalls. I've opened all ports between the two
machines, and the problem has gone away. 
Thanks very much for your help,
ds

Note You need to log in before you can comment on or make changes to this bug.