Bug 1355712 - python3 subpackage for python-txws
Summary: python3 subpackage for python-txws
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-txws
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ralph Bean
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PYTHON3
TreeView+ depends on / blocked
 
Reported: 2016-07-12 10:27 UTC by Lumír Balhar
Modified: 2016-07-12 13:49 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-07-12 13:49:43 UTC


Attachments (Terms of Use)
Enable Py3 support patch (2.37 KB, patch)
2016-07-12 10:28 UTC, Lumír Balhar
no flags Details | Diff

Description Lumír Balhar 2016-07-12 10:27:27 UTC
Hello Ralph.

Python-twisted is partially ported to Python3 and AFAIK Python3 support could be enabled in your package python-txws.

I've tried it and build looks good and installation of python3 subpackage and import in CLI as well, but there are no tests to prove that everything is really ok. Could you please check it?

Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=14869857

I will provide patch for specfile in minute.

Thank you and have a nice day.
Lumir

Comment 1 Lumír Balhar 2016-07-12 10:28 UTC
Created attachment 1178844 [details]
Enable Py3 support patch

Comment 2 Lumír Balhar 2016-07-12 10:33:26 UTC
I am also working on python-txzmq but there I asked upstream for a new release with a handy improvement. So I will fill a bug for this later.

Comment 3 Ralph Bean 2016-07-12 13:49:43 UTC
Thanks Lumír!  Applied and built in rawhide.  :)


Note You need to log in before you can comment on or make changes to this bug.