Bug 13558 - Install freezes when performing "post install configuration" while using updated disks
Install freezes when performing "post install configuration" while using upda...
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2000-07-06 22:07 EDT by Paul Morris
Modified: 2007-04-18 12:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-10-09 16:23:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Paul Morris 2000-07-06 22:07:20 EDT
Install dies when packages have been copied and while the "Performing post install configuration" message is displayed.
I have read previous errata, and used the "boot-20000407.img" boot disk with the "update-disk-20000419.img" update disk.


Gtk-CRITICAL **: file gtkaccelgroup.c: line 188 (gtk_accel_group_attach): assertion 'g_slist_find (accel_group->attach_objects, object) ==NULL' 

Gtk-CRITICAL **: file gtkaccelgroup.c: line 188 (gtk_accel_group_attach): assertion 'g_slist_find (accel_group->attach_objects, object) ==NULL' 
Exception in thread Thread-3:
Traceback (innermost last):
  File "/usr/lib/python1.5/threading.py", line 376, in __bootstrap self.run()
  File "/tmp/updates/iw/progress.py", line 16, in run rc = self.todo.doInstall ()
  File "/tmp/updates/todo.py", line 1246, in doInstall self.writeConfiguration ()
  File "/tmp/updates/todo.py", line 1059, in writeConfiguration self.writeNetworkConfig ()
  File "/tmp/updates/todo.py", line 533, in writeNetworkConfig ip = self.network.lookupHostname()
  File "/tmp/updates/todo.py", line 145, in lookupHostname self.gateway)
  File "/usr/lib/anaconda/isys.py", line 230, in configNetDevice return _isys.confignetDevice(device, ip, netmask, gw)
SystemError: (101, 'Network is unreachable')

Intel T440BX motherboard, 256MB RAM, 2 x 9gb uw-scsi hdd
with 1 x onboard intel eepro100 and 2 additional intel eepro100's.
All 3 cards were set to static ip's and were not connected to the network.

The system will replace an existing server so I cannot connect it to the network yet.
Can I assume from the previous messages that I must be connected to a network?
Comment 1 peederj 2000-07-17 20:52:54 EDT
I've gotten this one over and over again too.  I've tried on two different HP 
Pavilions...8590C and 8760C.  The prior Pavilion uses the RealTek8139-based 
networking card.  When using DHCP, it gets past this error, but then the 
network doesn't work.  I have a NAT router that serves as my gateway to the 
net.  I've tried every configuration I could think of, every parameter...
Comment 2 peederj 2000-07-17 20:59:44 EDT
BTW, I've applied the anaconda updates, to no avail.  Text mode and expert 
mode, specifying the RealTek card, to no avail.  There are other people that 
have seen this...e.g. at 


I think it's because the system isn't able to talk to the network.  A component 
is trying to configure itself and it asks the network about it.  I would love 
to have a simple way to get you the stack trace that comes up, ending 
in "SystemError 11 in ConfigNetDevice".

Please email me if you get a resolution to this!  I've reinstalled linux 25 
times on two different machines with no luck!  I have better things to do in 
Comment 3 peederj 2000-07-17 21:01:10 EDT
Another person who saw this, who seemed to have had success with the updates 
disk.  I had no luck...

Comment 4 peederj 2000-07-18 00:23:25 EDT
Finally it worked for me when I ripped out my Accton EN1207 (I, and Windows 
2000, had recognized it as Realtek 8139 earlier) and glued in an old EIDE 
Etherlink III which I had to hand-recognize in expert mode.  Unfortunately, 
while I do have eth0 running now I still can't see anything on my LAN.  But 
progress was made, and it did get through post install configuration without 
tripping up the error in Anaconda.
Comment 5 peederj 2000-07-18 00:37:24 EDT
And I'm obliged to add that EVERYTHING works PERFECT on the machine (which is 
dual-boot) when running Windows 2000.  I don't even have to set anything beyond 
the basic TCP/IP parameters including my static ip, subnet, gateway (my Netopia 
R9100 (NAT DSL) router's address) and two DNS providers and it works.  It also 
works over DHCP from the router.  I think my problem now has to do with setting 
the perfect network parameters in netcfg and linuxconf.  But the installer does 
die using my other card, you know, 100% reliably, and nothing should ever do 
that.  I guess your strategy is "permissive", i.e. see if it works, and if it 
crashes on some of the configurations out there, well, welcome to linux.
Comment 6 peederj 2000-07-18 12:44:11 EDT
I should also add, that RedHat 6.2 installed with nary a hitch on my Sony Vaio 
laptop PCG-Z505HS, provided I showed it where the PCMCIA CD-ROM was by 
typing "linux ide2=0x180,0x386" in the installer.  Manually entering the 
addresses for my router and such in the installer worked perfectly on the exact 
same LAN as the Pavilion.  I'm beginning to think that the Pavilion 8590C and 
8760C are simply incompatible with RedHat6.2 (and Corel Linux Deluxe, I tried 
that Debian distro too) in the networking department.  

Therefore, this bug report is about the installer failing in "post install 
configuration" when a network card is present but incompatible due to one 
glitch or another.  Both the networking problem, and the installer's 
robustness, need fixing.
Comment 7 peederj 2000-07-19 03:12:51 EDT
And finally, after peeing 5 days of my life down a hole over this, I have 
finally obtained and installed a "Tier 1 supported card" (the very capable 
Intel Pro/100+ Management Adapter) and suddenly everything starts working.  

Comment 8 Paul Morris 2000-07-19 20:58:26 EDT
The install competes OK when the 2 additional network cards were removed leaving only the single onboard eepro100.
The network cards worked fine when added later.
My guess is that the kernel was getting confused about setting up the routing tables or default gateway, and the Installer was waiting for it to finish. 
Wherever the problem lies, the installer should at least continue on so the problem can be resolved later.
Comment 9 Michael Fulbright 2000-10-09 16:23:03 EDT
We try to handle the numerous different hw configurations supported by the
kernel. Occasionally there are situations that are not handled as well.  It is a
continual process of improvement from release to release.

Note You need to log in before you can comment on or make changes to this bug.