Bug 1355856 - ipa otptoken-add --type=totp gives internal error
Summary: ipa otptoken-add --type=totp gives internal error
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords: Regression, TestBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 18:13 UTC by Varun Mylaraiah
Modified: 2016-11-04 05:57 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:57:41 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Varun Mylaraiah 2016-07-12 18:13:25 UTC
Description of problem:
ipa otptoken-add --type=totp gives internal error

Version-Release number of selected component (if applicable):
ipa-server-4.4.0-1.el7.x86_64

How reproducible:
100%

# ipa otptoken-add --type=totp 
ipa: ERROR: AttributeError: 'ResultFormattingError' object has no attribute 'type'
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1350, in run
    sys.exit(api.Backend.cli.run(argv))
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1115, in run
    rv = cmd.output_for_cli(self.api.Backend.textui, result, *args, **options)
  File "/usr/lib/python2.7/site-packages/ipaclient/plugins/otptoken.py", line 103, in output_for_cli
    qr = self._get_qrcode(output, uri, options['version'])
  File "/usr/lib/python2.7/site-packages/ipaclient/plugins/otptoken.py", line 83, in _get_qrcode
    "QR code width is greater than that of the output "
  File "/usr/lib/python2.7/site-packages/ipalib/messages.py", line 48, in add_message
    result.setdefault('messages', []).append(message.to_dict())
  File "/usr/lib/python2.7/site-packages/ipalib/messages.py", line 125, in to_dict
    type=unicode(self.type),
AttributeError: 'ResultFormattingError' object has no attribute 'type'
ipa: ERROR: an internal error has occurred


Expected results:


Additional info:

Comment 3 Petr Vobornik 2016-07-13 14:03:42 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6081

Comment 4 Petr Vobornik 2016-07-15 11:56:37 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/a5c8c9880d62dca50caa1cc8a77c3ae40225570b

Comment 6 Varun Mylaraiah 2016-07-22 12:20:47 UTC
Verified

# rpm -qa ipa-server
ipa-server-4.4.0-3.el7.x86_64

# ipa otptoken-add --type=totp
ipa: WARNING: QR code width is greater than that of the output tty. Please resize your terminal.
------------------
Added OTP token ""
------------------
  Unique ID: c208f5b4-3b2c-4bd3-951f-08bf57cb55a3
  Type: TOTP
  Owner: admin
  Manager: admin
  Key: dANIsjIGj90eCl6hM2QUVMXGaxA=
  Algorithm: sha1
  Digits: 6
  Clock offset: 0
  Clock interval: 30
  URI: otpauth://totp/admin@TESTRELM.TEST:c208f5b4-3b2c-4bd3-951f-08bf57cb55a3?digits=6&secret=OQBURMRSA2H52HQKL2QTGZAUKTC4M2YQ&period=30&algorithm=SHA1&issuer=admin%40TESTRELM.TEST


█████████████████████████████████████████████████████████████
█████████████████████████████████████████████████████████████
████ ▄▄▄▄▄ ██▀▄█▄█▄▀ ▄█▀▄ █▄█▄ ▄██ ▀▄▀▀▄▄▄███▀ ▀██ ▄▄▄▄▄ ████
████ █   █ █   ▄▄█ █▄█ ▀▄▄█▄█▄▄ ▄▀▄█ █▄█▀███▀ ▀▄▀█ █   █ ████
████ █▄▄▄█ █ ██▄▀▀██▄█▄▄ ▄█▀ ▄▄▄ █▀ ▄ ██▀█▀▀▄█ ███ █▄▄▄█ ████
████▄▄▄▄▄▄▄█ █▄▀▄█ ▀ █ ▀ ▀ ▀ █▄█ ▀ ▀▄▀ █ █ ▀▄▀▄▀ █▄▄▄▄▄▄▄████
████ █▄▄ ▄▄▀▀▄▀██▀██▄▄▀ █  █  ▄  ██▀█▄▄▄█▄▀▀▀▄▀ ██▄  ▄▄█▀████
████ ▄ █ █▄█▀▀▄█▀███▀█▀█▄▄▄ ▀   ▄▀▄██▄█▄  ▀▀▄██▀▄▀ ▄▄▀▀█▀████
████ ▀ ▄▄█▄▀█▀▀ ▀█▀█ █ ██▄▄ ▄ ▄▀ ▀█ ▀▄▄█▀█▀▄▄▀▄▀▀▄▀█ ▀ ▀ ████
████▄█▀▀▀▀▄▀▀█▀▀█ ▄▄▀▄▄█ ▀███▀   █  ▀▀ █ █▄▄▀▀ ▀▄█▀▄▀█▀  ████
████▀  █▄█▄ ▄▀ ▀█▄█ ▀▄▀▀ ▀▄▀▀▀▄█▀▄ ▀▄▀█▄▀▄▄▀█▀▄█▀  ▄ █▀▀▄████
████▀  ███▄ █▀▀█ ▄▄█▀▀▀█ ▄█  ▀▄█  ▀▄ █ █▄▄ █▀▀  ▀ █▄▄██  ████
████▄█ █▄▀▄▄▀███ ▀█ ▄ ██▀▄█▄   ▄█▄▀▀▄▄▄   █▀█▄▀█▄██▀  ▀ ▀████
████▄  ▄▄█▄▄▄▄▀ █▄▄▀  ▀█ ██▄   ▄██▄▄▀ █▄▀ ▀ █▀▀█ █▀▄▀█▀█ ████
████ ██▀ ▄▄▄ █ █▀█ ███▀▀  ▄▄ ▄▄▄ ▀▄▀█  ▀▄ ▄▀▀█ ▀ ▄▄▄ ▀▄▀█████
█████▄█▀ █▄█  ▀█ ▄█▄▀▀█▀▄▀▄█ █▄█ ▀ ▄█ ▀  █▄▀▀ ▄█ █▄█ ▀█▀▄████
████  ▄  ▄▄▄ ██  █▀▄▀▄▄█▄ ▀█  ▄ ▄▀█▄  ██▄█▀▀█ ▀▄  ▄▄▄▄▄  ████
████▄   ▀▄▄██▄█▀█▀  ▄▀▀▀▄▀  ▄▀█ █▄  ▄█▄▄▄▀▀█▄▄█▄█ ▄  ▄▀██████
████▄██▄▀ ▄ █▀▄▀█▀▄ █▄ █▄ █▀▀▀█ ▄▄ █ ▄ █ █ ▀▄▄▄▀ ▀█ ▀ ▀▀▀████
████▄ ▀█ █▄▄▄ ██▀▄▄ ▀█ ███▄   ███▄ ▄██ ▄ ███▀▀▄▀█▀▀▄ ▄█▀▀████
████▀▄▀█ █▄ ▀██▄▀▄   ▄▀▄▀ ▀█▄█▀▀▄▄▀▄ ▀█▄█▄▄█▀▀▀   ███▀ ▀▄████
████▄ █▀ █▄█   ▄█▄██▀▄▀ ▀▀ █▄▄▄▄▀ ██▄ ██▄██▀▄▀▀█▀▄  ▀▄▄█▀████
████ ▄██▄▀▄▀▄  ▄▄▀▄ ▄█▀▀█▀▄▄█▄▀▄▀▀ ▄▄ █▄  ▄▀▀██▄▀▀ ▄ ▀▀▀▀████
████▄ ▀▄▄▄▄▄▄█▀▀▄  █▀▀▀ █▀ ██▄▀▄ █    ▄  ███▀▄ ▀▄▀▀▀▀▀▄▀▀████
███████▄██▄▄▀█ ▄ █▄▀▄▄▄██▀▀█ ▄▄▄ █▄▄██ ▀  █▀ ▀▄█ ▄▄▄ ██▀█████
████ ▄▄▄▄▄ █▀█▄█▄▀▄▀▀█▀▄ ▄█▀ █▄█ █ ██▄▄▄▄█▄▀▀  █ █▄█ ▀█▀▄████
████ █   █ █ ▄ ▀▄▀ ▄▀  ▄█▄█▄▄ ▄▄▄ █▀█▄▄▄▄█▀ ▄▀ ▄  ▄▄▄█ █▄████
████ █▄▄▄█ █▄ █▀▀▀ █▄ █▀▄ ▀▄▀▄▄▀█ ▄█ ▄▄█▄▀▄█ ▀█▀▄▄▄▄▀▀▀ █████
████▄▄▄▄▄▄▄█▄██▄▄██▄▄██▄▄▄▄██▄▄█▄█████▄██▄▄▄▄█▄▄▄▄▄▄█▄███████
█████████████████████████████████████████████████████████████
▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀

Comment 8 errata-xmlrpc 2016-11-04 05:57:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.