Bug 135587 - Missing: Requires: libxml2-python >= 2.6.14
Missing: Requires: libxml2-python >= 2.6.14
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On: 160978
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 13:41 EDT by Jan Kratochvil
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-19 02:49:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2004-10-13 13:41:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040914

Description of problem:
Missing .spec keyword:

Requires: libxml2-python >= 2.6.14

(not sure if 2.6.14, just 2.5.11-1 is not enough)


Version-Release number of selected component (if applicable):
2.1.4-1

How reproducible:
Always

Steps to Reproduce:
After:
    yum update yum

from Fedora Core 1 to Fedora Core 3 test 3.


Actual Results:  Traceback (most recent call last):
  File "/usr/share/yum-cli/yummain.py", line 23, in ?
    import yum
  File "/usr/lib/python2.3/site-packages/yum/__init__.py", line 30, in ?
    import groups
  File "/usr/lib/python2.3/site-packages/yum/groups.py", line 3, in ?
    import comps
  File "/usr/lib/python2.3/site-packages/yum/comps.py", line 5, in ?
    import libxml2
ImportError: No module named libxml2


while
$ rpm -qa|grep -i xml2
libxml2-python-2.5.11-1
libxml2-2.5.11-1


Expected Results:  working yum


Additional info:

after
rpm -U libxml2-python-2.6.14-1.i386.rpm libxml2-2.6.14-1.i386.rpm

everything is fine.
Comment 1 Rahul Sundaram 2005-06-18 22:52:20 EDT
Should be closed now. This was probably a development issue which has been
resolved subsequently
Comment 2 Seth Vidal 2005-06-19 02:49:00 EDT
it was and now that yum uses python-elementtree it is moot
Comment 3 Jan Kratochvil 2005-06-19 09:19:25 EDT
I do not see how it could get fixed. yum-2.3.2-7 (of FC4) still has no specific
libxml2-python version dependency. yum-2.0.4-2 (of FC1) still tries to upgrade
to yum-2.3.2-7 (of FC4) without upgrading libxml2-python.
Unable to reproduce this bug with the latest yum-2.3.2-7 (of FC4) due to a glibc
upgrade bug: Bug 160978

Note You need to log in before you can comment on or make changes to this bug.