Bug 1355982 - qemu will abort after type two"system_reset" after the guest poweroff
Summary: qemu will abort after type two"system_reset" after the guest poweroff
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: All
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Markus Armbruster
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-13 08:07 UTC by Zhengtong
Modified: 2016-11-07 21:24 UTC (History)
10 users (show)

Fixed In Version: qemu-kvm-rhev-2.6.0-17.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 21:24:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description Zhengtong 2016-07-13 08:07:55 UTC
Description of problem:
I am not sure if this could be a bug. But qemu abort may not be a normal behaviour.

qemu will abort after typing "system_reset" for 2 times after the guest poweroff

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.6.0-12.el7 (not only happened on this version)

How reproducible:
100%

Steps to Reproduce:
1.boot up the guest with -no-shutdown option with qemu
#/usr/libexec/qemu-kvm \
...
-no-shutdown \
...
2.After the guest booting up. poweroff the guest inside guest
#poweroff
3.After the guest poweroff. type system_reset for 2 times.
(qemu) system_reset
(qemu) system_reset


Actual results:
qemu aborted.
Here is the result with gdb info
(qemu) system_reset
(qemu) system_reset
(qemu) 2016-07-13T07:34:52.661230Z qemu-kvm: invalid runstate transition: 'prelaunch' -> 'prelaunch'

Program received signal SIGABRT, Aborted.
0x00003fffb6b2eb18 in raise () from /lib64/libc.so.6
Missing separate debuginfos, use: debuginfo-install alsa-lib-1.1.1-1.el7.ppc64le bzip2-libs-1.0.6-13.el7.ppc64le cyrus-sasl-lib-2.1.26-20.el7_2.ppc64le cyrus-sasl-md5-2.1.26-20.el7_2.ppc64le dbus-libs-1.6.12-14.el7.ppc64le elfutils-libelf-0.166-2.el7.ppc64le elfutils-libs-0.166-2.el7.ppc64le flac-libs-1.3.0-5.el7_1.ppc64le glib2-2.46.2-3.el7.ppc64le glibc-2.17-155.el7.ppc64le gmp-6.0.0-12.el7_1.ppc64le gnutls-3.3.23-8.el7.ppc64le gperftools-libs-2.4-8.el7.ppc64le gsm-1.0.13-11.el7.ppc64le json-c-0.11-4.el7_0.ppc64le keyutils-libs-1.5.8-3.el7.ppc64le krb5-libs-1.14.1-18.el7.ppc64le libICE-1.0.9-2.el7.ppc64le libSM-1.2.2-2.el7.ppc64le libX11-1.6.3-3.el7.ppc64le libXau-1.0.8-2.1.el7.ppc64le libXext-1.3.3-3.el7.ppc64le libXi-1.7.4-2.el7.ppc64le libXtst-1.2.2-2.1.el7.ppc64le libaio-0.3.109-13.el7.ppc64le libasyncns-0.8-7.el7.ppc64le libattr-2.4.46-12.el7.ppc64le libcacard-2.5.2-2.el7.ppc64le libcap-2.22-8.el7.ppc64le libcom_err-1.42.9-9.el7.ppc64le libcurl-7.29.0-32.el7.ppc64le libdb-5.3.21-19.el7.ppc64le libfdt-1.4.0-2.el7.ppc64le libffi-3.0.13-18.el7.ppc64le libgcc-4.8.5-8.el7.ppc64le libgcrypt-1.5.3-12.el7_1.1.ppc64le libgpg-error-1.12-3.el7.ppc64le libibverbs-1.2.0-2.el7.ppc64le libidn-1.28-4.el7.ppc64le libiscsi-1.9.0-7.el7.ppc64le libnl3-3.2.28-0.1.el7.ppc64le libogg-1.3.0-7.el7.ppc64le libpng-1.5.13-7.el7_2.ppc64le librdmacm-1.1.0-2.el7.ppc64le libselinux-2.5-4.el7.ppc64le libsndfile-1.0.25-10.el7.ppc64le libssh2-1.4.3-10.el7_2.1.ppc64le libstdc++-4.8.5-8.el7.ppc64le libtasn1-3.8-2.el7.ppc64le libusbx-1.0.20-1.el7.ppc64le libuuid-2.23.2-30.el7.ppc64le libvorbis-1.3.3-8.el7.ppc64le libxcb-1.11-4.el7.ppc64le lzo-2.06-8.el7.ppc64le nettle-2.7.1-5.el7.ppc64le nspr-4.11.0-1.el7_2.ppc64le nss-3.21.0-17.el7.ppc64le nss-softokn-freebl-3.16.2.3-14.4.el7.ppc64le nss-util-3.21.0-2.2.el7_2.ppc64le numactl-libs-2.0.9-6.el7_2.ppc64le openldap-2.4.40-12.el7.ppc64le openssl-libs-1.0.1e-58.el7.ppc64le p11-kit-0.20.7-3.el7.ppc64le pcre-8.32-15.el7_2.1.ppc64le pixman-0.34.0-1.el7.ppc64le pulseaudio-libs-6.0-8.el7.ppc64le snappy-1.1.0-3.el7.ppc64le systemd-libs-219-22.el7.ppc64le tcp_wrappers-libs-7.6-77.el7.ppc64le trousers-0.3.13-1.el7.ppc64le xz-libs-5.2.2-1.el7.ppc64le zlib-1.2.7-17.el7.ppc64le
(gdb) 


Expected results:
No aborted for qemu

Additional info:

Comment 1 Zhengtong 2016-07-13 08:11:04 UTC
(gdb) bt
#0  0x00003fffb6b2eb18 in raise () from /lib64/libc.so.6
#1  0x00003fffb6b30c9c in abort () from /lib64/libc.so.6
#2  0x0000000046437924 in runstate_set (new_state=<optimized out>) at vl.c:699
#3  0x0000000046275dbc in main_loop_should_exit () at vl.c:1902
#4  main_loop () at vl.c:1938
#5  main (argc=<optimized out>, argv=<optimized out>, envp=<optimized out>) at vl.c:4667

Comment 3 Markus Armbruster 2016-07-26 08:58:35 UTC
Fixed upstream in commit e92a2d9cb3d8f589c9fe5d2eacc83d8dddea0e16.

Comment 4 Miroslav Rezanina 2016-07-29 09:12:21 UTC
Fix included in qemu-kvm-rhev-2.6.0-17.el7

Comment 6 yduan 2016-08-22 07:07:33 UTC
Reproduced with qemu-kvm-rhev-2.6.0-12.el7.x86_64, verified with qemu-kvm-rhev-2.6.0-17.el7.x86_64/qemu-kvm-rhev-2.6.0-21.el7.x86_64.

Steps to reproduce are same as comment 0.

Comment 9 errata-xmlrpc 2016-11-07 21:24:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.