Bug 1356053 - [de_DE] The word "Deutsch" should not appear in welcome page's 'docs missing' message
Summary: [de_DE] The word "Deutsch" should not appear in welcome page's 'docs missing'...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: Scott Dickerson
QA Contact: Yuko Katabami
URL:
Whiteboard:
Depends On: 1435402
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-13 10:33 UTC by Krishna Babu K
Modified: 2019-05-16 13:03 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-04-23 17:36:11 UTC
oVirt Team: UX
Target Upstream Version:


Attachments (Terms of Use)
Screen shot reference for the reported issue. (207.65 KB, image/png)
2016-07-13 10:33 UTC, Krishna Babu K
no flags Details
fixed (30.92 KB, image/png)
2017-11-02 19:54 UTC, Greg Sheremeta
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 0 normal SHIPPED_LIVE Red Hat Virtualization Manager (ovirt-engine) 4.2 GA 2018-06-07 17:27:12 UTC
oVirt gerrit 82733 0 master MERGED core: update welcome page error for missing localized docs 2017-10-13 16:33:10 UTC

Description Krishna Babu K 2016-07-13 10:33:56 UTC
Created attachment 1179212 [details]
Screen shot reference for the reported issue.

Description of problem:
  When clicking 'Release Notes' link on RHEVM welcome page with de_DE locale, the information message appeared on corresponding page is "Die Deutsch Dokumentation scheint nicht installiert zu sein...". Here "Deutsch" must be changed to "deutsche" but not available on zanata to update the same.

Version-Release number of selected component (if applicable):
Version 4.0.2-0.2.rc1.el7ev

How reproducible:


Steps to Reproduce:
1. Access the RHEVM welcome page with de_DE locale.
2. Click on 'Release Notes' link.
3. Observe the information message appeared on the corresponding page.

Actual results:
 Message has "Deutsch"

Expected results:
 Message should have "deutsche"

Additional info:
 Screen-shot attached for reference.

Comment 1 Yuko Katabami 2017-02-14 13:42:10 UTC
I cannot find this string in Zanata.
What is the English version of the message?
I used 4.1.0.3-0.1.el7 to check it but I could not reproduce the message.

Comment 3 Yuko Katabami 2017-02-15 22:56:54 UTC
Hi Krishna,

I was able to see the page after clearing cache/cookies.

I located the string in Zanata.

File: backend/manager/modules/docs/src/main/resources/messages

Source: It appears that you do not have the {0} documentation installed.
Target: Die  {0} Dokumentation scheint nicht installiert zu sein.

Obviously, the word "Deutsch" is mapped to the variable {0} but I am not able to locate it within this project.
The translation must be located somewhere else.


The source code is here: https://github.com/oVirt/ovirt-engine/blob/e06859fef6c38a955a4e0e1f6b0ddaa1e8eae8fb/backend/manager/modules/docs/src/main/resources/messages.properties


by Alex

@Alex, could you please take a look at this bug?

Comment 4 Alexander Wels 2017-02-27 13:32:30 UTC
@Yuko,

That variable is resolved using the Java locale system. It basically contains objects that return text form when you pass in for instance de_DE. I misused that variable in the message. I think the best option would be to have the text translated, but if I put English in the English message, I am not sure if the translators would actually translate that (which is why I went with the locale object value in the first place).

Any suggest on how I can hint to the translators to change 'English' to whatever locale they are working in?

Comment 5 Yuko Katabami 2017-02-27 14:19:11 UTC
Hi Alex,

Tricky part is that only a single translator needs to translate their own locale name (so no point adding all lang names to Zanata, as if you do, those locale names will be translated into 7 languages).

Is there a way to find more adequate locale object values that can be correctly used?

(sorry, not much of help)

Comment 6 Scott Dickerson 2017-10-12 04:08:17 UTC
Yuko - I took another look at how the message is setup.  There isn't another way to ask Java for a language's name in different grammatical usages.  The only way to accommodate this BZ seems to be to:
  1. change the wording on the message, and
  2. change the comments in the property file so the comment hint in Zanata
     gives some context to the message.  (I double checked - on a push, 
     Zanata will take any comments directly above and attached to a key/message
     line and show it as a source comment on the UI)

I propose rewording the message from "It appears that you do not have the {0} documentation installed." to "It appears that you do not have the local language documentation installed."

Additionally, add the following comment for Zanata to display to translators - "NOTE: Message should directly reference the local language's name."

With those 2 small changes, I think translators will know what to do and we don't have to rely on Java's "Display Language" to be grammatically correct.

Comment 7 Yuko Katabami 2017-10-12 05:27:25 UTC
Thank you very much for looking into it, Scott.

To avoid misunderstanding by translators, it can be further changed to:

"It appears that this document is not available in your language."


What do you think?

Comment 8 Scott Dickerson 2017-10-12 14:50:52 UTC
I'll add a "currently" so the message also implies that it could be available in future.

Comment 9 Yuko Katabami 2017-10-12 20:49:17 UTC
Thank you very much, Scott.

Comment 11 Yaniv Kaul 2017-10-15 08:51:50 UTC
Can this BZ moved to MODIFIED, or are additional patches are needed?

Comment 12 Greg Sheremeta 2017-10-15 12:02:19 UTC
No other patches are needed, but it won't pass QA until the first translation update.

Comment 14 Yuko Katabami 2017-11-02 19:12:18 UTC
The translation cycle #1 was completed last week and I have confirmed that this string has been changed to "It appears that this document is not currently available in your language." and no longer uses the variable that caused the grammatical error.

I have not verified the change on the UI yet but would this be sufficient to pass QA?

Comment 15 Greg Sheremeta 2017-11-02 19:54:35 UTC
Created attachment 1347111 [details]
fixed

Thanks Yuko. I verified in UI too. (attached)

Comment 16 Yuko Katabami 2017-11-02 21:48:13 UTC
(In reply to Greg Sheremeta from comment #15)
> Created attachment 1347111 [details]
> fixed
> 
> Thanks Yuko. I verified in UI too. (attached)

Thank you Greg.

Comment 17 Greg Sheremeta 2018-04-23 17:36:11 UTC
This message is actually deleted in 4.2 GA.

Comment 19 Franta Kust 2019-05-16 13:03:21 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.