Bug 1356146 - performance regression in CLI help
Summary: performance regression in CLI help
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa   
(Show other bugs)
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
Aneta Šteflová Petrová
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-13 13:29 UTC by Petr Vobornik
Modified: 2016-11-04 05:58 UTC (History)
5 users (show)

Fixed In Version: ipa-4.4.0-8.el7
Doc Type: Bug Fix
Doc Text:
Displaying help for the IdM command-line interface no longer takes unexpectedly long When the user executes the *ipa* utility with the "--help" option, *ipa* gathers the required information from plug-ins and commands. Previously, the plug-ins and commands were Python modules. With this release, *ipa* generates the plug-ins and commands based on a schema downloaded from the server. Because of this, displaying the help sometimes took significantly longer than in the previous version of Identity Management (IdM), especially if the help included lists of topics and commands. This bug has been fixed, which reduces the time required to execute *ipa* with "--help".
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 05:58:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Petr Vobornik 2016-07-13 13:29:31 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/6048

executing `ipa help <anything>` takes 6+ seconds. This is a performance regression caused by thin client effort. 

`ipa help` should be at least as quick(1-2s?) as in versions prior 4.4. Ideally faster.

Comment 2 Petr Vobornik 2016-08-12 13:09:45 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6170

Comment 9 Nikhil Dehadrai 2016-09-13 10:17:34 UTC
IPA-server-version: ipa-server-4.4.0-11.el7.x86_64

Verified the bug on the basis of following steps:
1. Verified that performance of 'ipa help commands' is significantly improved with latest ipa server version and corresponding regression issue mentioned in description is not observed.
2. Kindly refer the below console output:
==========
RHEl7.3
==========
#rpm -q ipa-server && time ipa help commands 1>/dev/null
ipa-server-4.4.0-10.el7.x86_64
 
real    0m0.724s
user    0m0.380s
sys     0m0.039s
 
==========
RHEL7.2.z
==========
# rpm -q ipa-server && time ipa help commands 1>/dev/null
ipa-server-4.2.0-15.el7_2.19.x86_64
 
real    0m0.458s
user    0m0.372s
sys     0m0.079s

Thus on the basis of above points marking status of bug to "VERIFIED"

Comment 16 errata-xmlrpc 2016-11-04 05:58:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.