Bug 135622 - Kernel Badness Error on Shutdown
Summary: Kernel Badness Error on Shutdown
Status: CLOSED DUPLICATE of bug 132726
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-10-13 20:42 UTC by Christopher Stone
Modified: 2015-01-04 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:06:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher Stone 2004-10-13 20:42:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041012
Firefox/0.10.1

Description of problem:
Upon shutdown, sometime between NFS and CFS I get a kernel Badness
error, details below. 

Oct 11 09:34:16 lothlorien nfs: Shutting down NFS services:  succeeded
Oct 11 09:34:16 lothlorien sshd: sshd -TERM succeeded
Oct 11 09:34:16 lothlorien kernel: Badness in
interruptible_sleep_on_timeout at
kernel/sched.c:3004
Oct 11 09:34:16 lothlorien kernel:  [<022f7ba4>]
interruptible_sleep_on_timeout+
0x5d/0x23a
Oct 11 09:34:16 lothlorien kernel:  [<0211b5bd>]
default_wake_function+0x0/0xc
Oct 11 09:34:16 lothlorien kernel:  [<32aa19e6>] lockd_down+0xb4/0x258
[lockd]
Oct 11 09:34:16 lothlorien kernel:  [<32b7340a>]
nfs_kill_super+0x43/0x63 [nfs]
Oct 11 09:34:16 lothlorien kernel:  [<02167d56>]
deactivate_super+0xcb/0xe0
Oct 11 09:34:16 lothlorien kernel:  [<021848cc>] sys_umount+0x65/0x6c
Oct 11 09:34:16 lothlorien kernel:  [<0217f60b>] destroy_inode+0x36/0x45
Oct 11 09:34:16 lothlorien kernel:  [<0217b0a3>] dput+0x33/0x4f3
Oct 11 09:34:16 lothlorien kernel:  [<021624c6>] __fput+0xc9/0xee
Oct 11 09:34:16 lothlorien kernel:  [<021848de>] sys_oldumount+0xb/0xe
Oct 11 09:34:16 lothlorien cfsd: Unmounting CFS dir:  succeeded
Oct 11 09:34:16 lothlorien cfsd: cfsd shutdown succeeded


Version-Release number of selected component (if applicable):
kernel-2.6.8-1.607

How reproducible:
Always

Steps to Reproduce:
Not sure, is this caused by shutting down CFS after NFS?  CFS relies
on NFS, I will try reordering the shutdown of these to see if it fixes
the error.    

Additional info:

Comment 1 Christopher Stone 2004-10-13 21:45:15 UTC
Reordering the shutdown of CFS so that it shuts down prior to NFS
fixes the problem.

Comment 2 Christopher Stone 2004-10-14 21:11:54 UTC
This appears to be a duplicate of bug 132726

Comment 3 Christopher Stone 2004-10-16 02:12:09 UTC

*** This bug has been marked as a duplicate of 132726 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:06:18 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.