Bug 135629 - wireless nic and builtin nic both claim eth0
wireless nic and builtin nic both claim eth0
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 17:35 EDT by Jim Snow
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 11:31:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Snow 2004-10-13 17:35:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
I am using a thinkpad T21 with builtin nic (Ethernet Pro 100 according
to lspci), which claims eth0 using the e100 driver.  I also have a
pcmcia US Robotics wireless card that uses the orinoco_cs driver.

If I insert the wireless card before enabling the wired ethernet, the
wireless driver claims eth0, but fails to function.  If I then remove
the wireless card and run "ifconfig", the mac address of the wired
eth0 is displayed, but without any of the usual statistics (RX
packets, TX packets, etc...).  If I then enable the card with
"ifconfig eth0 up" and insert the wireless card, the wireless card
claims eth1 (as it should) and works correctly.

Version-Release number of selected component (if applicable):
2.6.8-1.521

How reproducible:
Always

Steps to Reproduce:
1.boot machine
2.insert wireless card
3.
    

Actual Results:  wireless card fails to function, claiming a device
name already in use by builtin card (eth0)

Expected Results:  device claims device name eth1 and works correctly

Additional info:

/etc/modprobe.conf has a line:

alias eth0 e100
Comment 1 Andrew D. Stadler 2004-10-18 22:52:03 EDT
I have similar problems with a T30 laptop.  The difference is that my wireless is built-in 
(Prism 2.5) so I cannot "pop out" the card !!!

This problem is critical because it causes networking to fail, or become funky, with little 
recourse to fixing it.   (for example, when wired networking moves to eth1, software 
locked using FlexLM no longer recognizes the MAC address on eth0).

I would like to provide some additional clues:
  1.  Per newsgroups, it seems to be affected by *availability of nearby wireless networks*.  
I have struggled most of this afternoon trying to get the wired connection back onto eth0.  
Finally, i pulled the plug on my wireless router and it *immediately* went back to normal 
behavior.    I rebooted a couple of times and it solidly remained on eth0.

  2.  Regression test - I plugged the wireless base stn. back in and rebooted.  kudzu did 
not do anything out of the ordinary.  

  3.  I see that there are also submitted bugs about the Prism2.5 card showing up as 
"Ethernet" preventing proper choice of a driver and proper initialization of wireless 
settings.  I have that too.

  4.  system-config-network also insists on displaying "eth2" with the Intel EtherExpress/
100 driver.  I never put it there, and eth2 doesn't show up in kudzu -p but somebody 
wrote it into modprobe.conf.
Comment 2 Dave Jones 2004-10-27 01:19:22 EDT
system-config-network should be binding interfaces to NICs based upon their MAC
address. This doesn't look like a kernel bug.
Comment 3 Harald Hoyer 2004-10-27 04:41:01 EDT
Jim Snow: 
You should execute system-config-network and bind the interface name
to the MAC address!

Note You need to log in before you can comment on or make changes to this bug.