Bug 1356484 - Gnome Maps cannot use MapQuest tiles anymore
Summary: Gnome Maps cannot use MapQuest tiles anymore
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-maps
Version: 23
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-14 08:57 UTC by talles
Modified: 2016-08-02 19:53 UTC (History)
13 users (show)

Fixed In Version: gnome-maps-3.18.3.1-1.fc23 gnome-maps-3.20.2-1.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1361868 (view as bug list)
Environment:
Last Closed: 2016-08-02 19:49:44 UTC


Attachments (Terms of Use)
The error message with the About message on top (196.13 KB, image/png)
2016-07-14 08:57 UTC, talles
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 764841 None None None 2016-07-20 14:28:38 UTC

Description talles 2016-07-14 08:57:18 UTC
Created attachment 1179681 [details]
The error message with the About message on top

Description of problem:
As of 11 July MapQuest does not allow direct access to their map tiles. See http://www.goo.gl/xBOxXt for more information.

Version-Release number of selected component (if applicable):
I have 3.18.2, but I guess this affects all versions, as they all use MapQuest tiles.

How reproducible:
Open Gnome Maps, it does not show a map. Maybe caching hides the issue at first, so go to a place on the map that you did not visit lately.

Actual results:
An error page of MapQuest with the above mentioned link

Expected results:
A map of (a part of) the world

Additional info:

Comment 1 talles 2016-07-14 08:59:33 UTC
Here is a similar bug report at Ubuntu https://bugs.launchpad.net/ubuntu/+source/gnome-maps/+bug/1602035

Comment 2 fednuc 2016-07-14 20:42:12 UTC
Applies to all versions shipping gnome-maps pretty much, can someone fix the version field?

Upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=764841

Also, talles@sogyo.nl, the shortened goo.gl link you posted is broken. I don't know if there is a RHBZ policy against link shorteners, but can you post the original link?

Comment 3 Scott Dowdle 2016-07-15 02:31:12 UTC
The URL to the Mapquest blog post is:
http://devblog.mapquest.com/2016/06/15/modernization-of-mapquest-results-in-changes-to-open-tile-access/

Comment 4 Fedora Update System 2016-07-30 22:21:51 UTC
gnome-maps-3.20.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b98e3831e7

Comment 5 Fedora Update System 2016-07-30 22:22:37 UTC
gnome-maps-3.18.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-bc76866e34

Comment 6 Christian Klomp 2016-07-31 19:26:05 UTC
gnome-maps-3.18.3.1.fc23 doesn't work:

(org.gnome.Maps:8212): Gjs-WARNING **: JS ERROR: Error: No property 'projection' in property list (or its value was undefined)
_createTileSource@resource:///org/gnome/Maps/js/mapSource.js:55
_createCachedSource@resource:///org/gnome/Maps/js/mapSource.js:70
createStreetSource@resource:///org/gnome/Maps/js/mapSource.js:105
MapView<.setMapType@resource:///org/gnome/Maps/js/mapView.js:160
wrapper@resource:///org/gnome/gjs/modules/lang.js:169
MapView<._init@resource:///org/gnome/Maps/js/mapView.js:84
wrapper@resource:///org/gnome/gjs/modules/lang.js:169
MainWindow<._init@resource:///org/gnome/Maps/js/mainWindow.js:76
wrapper@resource:///org/gnome/gjs/modules/lang.js:169
Application<._createWindow@resource:///org/gnome/Maps/js/application.js:236
wrapper@resource:///org/gnome/gjs/modules/lang.js:169
Application<.vfunc_activate@resource:///org/gnome/Maps/js/application.js:250
wrapper@resource:///org/gnome/gjs/modules/lang.js:169
main@resource:///org/gnome/Maps/js/main.js:47
run@resource:///org/gnome/gjs/modules/package.js:192
start@resource:///org/gnome/gjs/modules/package.js:176
@/usr/bin/gnome-maps:5

Comment 7 Dominik Grafenhofer 2016-07-31 19:41:04 UTC
@Christian: strange, gnome-maps-3.18.3-1.fc23.x86_64 works for me...

Comment 8 Fedora Update System 2016-08-01 09:43:16 UTC
gnome-maps-3.18.3.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8a13c24990

Comment 9 Kalev Lember 2016-08-01 09:46:10 UTC
gnome-maps-3.18.3.1-1.fc23 should fix the crash on startup.

Comment 10 Christian Klomp 2016-08-01 10:09:05 UTC
@Kalev: that did it, maps seems to be functioning as before the MapQuest break.

Comment 11 Fedora Update System 2016-08-01 20:53:48 UTC
gnome-maps-3.18.3.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8a13c24990

Comment 12 Fedora Update System 2016-08-01 20:57:51 UTC
gnome-maps-3.20.2-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b98e3831e7

Comment 13 Fedora Update System 2016-08-02 19:49:38 UTC
gnome-maps-3.18.3.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2016-08-02 19:53:02 UTC
gnome-maps-3.20.2-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.