Bug 13565 - logrotate.d/linuxconf requires missingok.
Summary: logrotate.d/linuxconf requires missingok.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-07 12:00 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-24 13:32:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-07-07 12:00:35 UTC
Linuxconf logrotate.d entries need missingok or equivalent in them; if
you never use linuxconf, root will still get mailed his dosage of errors..

Comment 1 Nalin Dahyabhai 2000-07-19 14:20:14 UTC
The %post script for linuxconf creates these logs, so they're there.

Comment 2 Pekka Savola 2000-07-24 11:15:50 UTC
(beta4, linuxconf-1.19r1-7)

Clean install is fine; upgrade is not.

After an _upgrade_ of RH60 and/or RH62, I got mails like:
---
errors occured while rotating /var/log/htmlaccess.log

stat of /var/log/htmlaccess.log failed: No such file or directory
---
errors occured while rotating /var/log/netconf.log

stat of /var/log/netconf.log failed: No such file or directory
---

---
# rpm -V linuxconf
SM5....T c /etc/conf.linuxconf
---

This might be caused by the fact that in RH6x, those files are in package list,
but in betas they should be touched in post-install.


Comment 3 Nalin Dahyabhai 2000-07-24 13:32:08 UTC
Okay, that's bad, because that means an older version of the package
is *removing* that file on uninstall.  I'll have to add a trigger to get around
it.

Comment 4 Nalin Dahyabhai 2000-07-24 13:40:19 UTC
Trigger should be in linuxconf-1.19r1-9 and later.


Note You need to log in before you can comment on or make changes to this bug.