Bug 135651 - kernels 2.6.8-1.607 and above consistently crash on reboot
Summary: kernels 2.6.8-1.607 and above consistently crash on reboot
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-10-14 01:35 UTC by Michal Jaegermann
Modified: 2015-01-04 22:10 UTC (History)
4 users (show)

Fixed In Version: 2.6.9-1.640
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-27 11:41:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2004-10-14 01:35:18 UTC
Description of problem:

At least kernels 2.6.8-1.607, 2.6.8-1.609 and 2.6.8-1.610 crash
on reboot.  The crash is consistent.  It is always in a process
reboot and RIP says find_isa_irq_pin+1.  The next line is
"INIT: No more processes left in this runlevel"
and a machine is frozen solid.

This happens after everything got unmounted so nothing in logs.
Information scrolls off the screen and there is no way to get back.
If necessary I may try to set later a capture on a serial console.

'shutdown -h now' does not have such nasty effects and computer
powers off without any crashes while 'shutdown -r now' is truly
equivalent to 'reboot'.

I think that this was not happening with 2.6.8-1.603 but I am not
sure.   Maybe I never tried to reboot and I cannot find that
kernel anymore nor I have a copy.  Definitely nothing like that
I see with kernel-2.6.8-1.541

I also did not observe that on an x86 machine (although there
recently kernels stopped powering off with 'poweroff' while
'shutdown -h now' still powers off a machine).

Version-Release number of selected component (if applicable):
2.6.8-1.607, 2.6.8-1.610

How reproducible:
100%

Steps to Reproduce:
boot, level 1 is enough, type 'reboot' and wait a bit

Comment 1 Robert Hancock 2004-10-14 04:21:42 UTC
Think this should be fixed in the code stream now, see
http://groups.google.com/groups?q=find_isa_irq_pin+group:linux.kernel&hl=en&lr=&selm=2NUPO-6lN-23%40gated-at.bofh.it&rnum=2

Comment 2 Robert Hancock 2004-10-14 04:22:54 UTC
.. though that was in i386 arch code, maybe not fixed in x86_64?

Comment 3 Michal Jaegermann 2004-10-14 04:41:01 UTC
Other pieces of a trace which show up on my screen make a cause
mentioned in comment #1 very probable.  Only this definitely showed
up quite recently and bombs always and on x86_64.

One would think that disable_IO_APIC() could check for find_isa_irq_pin.
If we are rebooting then do we really care about that information?

Comment 4 Neal Becker 2004-10-16 14:54:42 UTC
I see the same thing.  Still there as of 2.6.8-1.610 x86_64. 
 

Comment 5 Dave Jones 2004-10-27 05:21:46 UTC
this should be fixed in current kernels.
confirm ?


Comment 6 Michal Jaegermann 2004-10-27 05:30:46 UTC
Indeed this is the case AFAICS.  It is even quite clear what
was the reason. :-)  Neal?

Comment 7 Neal Becker 2004-10-27 11:26:56 UTC
THe problem I reported was only x86_64, and is fixed.  I just 
remotely rebooted my x86_64 running .640. 


Note You need to log in before you can comment on or make changes to this bug.