Bug 135661 - Perl should obsolete perl-MIME-Base64 <= 3.01 or deliver >= 3.03
Summary: Perl should obsolete perl-MIME-Base64 <= 3.01 or deliver >= 3.03
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact:
URL: http://www.mail-archive.com/mimedefan...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-14 07:00 UTC by Robert Scheck
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 5.8.6-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-20 18:55:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
perl-5.8.5-MIME-Base64-3.05.patch (11.07 KB, patch)
2004-10-14 07:01 UTC, Robert Scheck
no flags Details | Diff

Description Robert Scheck 2004-10-14 07:00:45 UTC
Description of problem:
If I want to use MimeDefang with Fedora Core 2 or 3/Devel, I've got 
to use perl MIME::tools in an actual version (5.413), which requires
perl MIME::Base64 >= 3.03, but perl-5.8.5-9 only delivers the old 
3.01.

A third-party package (using the perl site directory) solves the 
problems until the perl-core package is updated, then the perl core 
package tries to obsolete the newer MIME::Base64 and updating of 
perl-core fails.

I worked out two solutions which would be both okay for me and none 
of them should really hurt Red Hat ;-)

  a) Change the "Obsoletes: perl-MIME-Base64" to "Obsoletes: perl-MIME-Base64"

or:

  b) Upgrade the MIME::Base64 the perl core package to >= 3.03, for 
     this I'll attach a patch.

Version-Release number of selected component (if applicable):
perl-5.8.5-9

Actual results:
This problem is only indirect a Red Hat related problem, but it 
would be fine, if this problem could be solved by Red Hat, that no
nasty workarounds are necessary by third-party people.

Expected results:
a) or b), but I would prefer b) because a newer MIME::Base64 will
come some time, I guess.

Comment 1 Robert Scheck 2004-10-14 07:01:53 UTC
Created attachment 105187 [details]
perl-5.8.5-MIME-Base64-3.05.patch

Comment 2 Robert Scheck 2004-11-19 09:29:27 UTC
Ping?

Comment 3 Robert Scheck 2005-01-20 18:55:20 UTC
Perl 5.8.6 contains MIME::Base64 = 3.05, so I'll close this bug, 
because perl-5.8.6-2 is in Rawhide.


Note You need to log in before you can comment on or make changes to this bug.