Bug 135671 - Settup for more languages during installation has no effect
Settup for more languages during installation has no effect
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-14 05:54 EDT by reuven
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 04:33:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description reuven 2004-10-14 05:54:37 EDT
Description of problem:

I asked at installation time to work with 3 languages: english, hebrew
and russian.

The GNOME has been installed only with english keyboard layout, and I
had to add manually the other 2 languages, and they work.

The KDE has also been installed only with english keyboard layout, and
when I wanted to add languages, I got a void list of available
languages, so I could not add any additional language.


Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. Ask to use 3 languages during installation time.
2.
3.
  
Actual results:
GNOME comes with English layout only, and one has to add manually the
other 2 languages. KDE also comes with English layout only, and when
trying to add other languages, the list is void.

Expected results:
GNOME and KDE should be set with 3 keyboad layout languages.

Additional info:
Comment 1 Paul Nasrat 2004-10-14 06:26:07 EDT
What languages get listed if you run system-config-keyboard post install

System Settings->Keyboard

If you change system wide keyboard setting does gnome behave as desired?
Comment 2 reuven 2004-10-14 09:13:48 EDT
All the languages are available to be added, post install, in gnome.
After adding to panel the keyboard applet, and adding the desired
languages, gnome behaves as desired.
Comment 3 Paul Nasrat 2004-10-14 09:20:12 EDT
I was asking about system-config-keyboard not the
gnome-keyboard-properites.  Please either use System
Settings->Keyboard from the menu or run system-config-keyboard  from a
terminal do you see multiple layouts?

Note system-config-keyboard sets the X keyboard layout rather than a
personal preference.
Comment 4 reuven 2004-10-15 03:17:36 EDT
The languages listed when running system-config-keyboard: a very long
list, starting from Belgian(be-latin1) and ending with U.S.
International. On my system, the selected keyboard is U.S. English
Comment 5 Paul Nasrat 2004-10-15 03:40:14 EDT
And if you run system-config-language?
Comment 6 reuven 2004-10-15 04:06:34 EDT
system-config-language offers 3 possibilities: english, hebrew and
russian.

If I understand what you mean: this is not a bug, and the setup in
Anaconda is supposed to chose the possible languages of the window
managers, and not the working languages - is it so?

If it is so, I think the concept is wrong, because the language of the
window managers are easy to choose before any Session, but the working
languages, i.e. the languages one needs to type with, are more tricky,
and user friendlyness would imply an automatic setup.
Comment 7 Paul Nasrat 2004-10-15 04:33:24 EDT
Anaconda makes choices about things like fonts to install, etc based
on language support.

I agree it is confusing, I'm not going to be able to look at improving
this until post fc3 as we're in freeze.  I'm going to close as
deferred, but re-open or open a new RFE for better language
integration.  I will comment on this bug when that happens.

In particular the interaction between the sytem-* tools and individual
preferences is not great right now.

Note You need to log in before you can comment on or make changes to this bug.