Bug 1356713 - Scrollbars do not Appear on Pages that Require Them in Horizon
Summary: Scrollbars do not Appear on Pages that Require Them in Horizon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Radomir Dopieralski
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks: 1364556
TreeView+ depends on / blocked
 
Reported: 2016-07-14 20:14 UTC by Dustin Schoenbrun
Modified: 2016-12-14 15:46 UTC (History)
7 users (show)

Fixed In Version: python-django-horizon-10.0.0-0.20161002185148.3252153.4.el7ost
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
: 1364556 (view as bug list)
Environment:
Last Closed: 2016-12-14 15:46:05 UTC


Attachments (Terms of Use)
A view of the compute overview with no scroll bar (67.11 KB, image/png)
2016-07-14 20:14 UTC, Dustin Schoenbrun
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Dustin Schoenbrun 2016-07-14 20:14:41 UTC
Created attachment 1179944 [details]
A view of the compute overview with no scroll bar

Description of problem:
When viewing various pages in the Horizon UI for Red Hat OpenStack Platform it is possible for the content of the page to be longer than the current browser window can display. However, currently there is no way to scroll in these pages. Scrolling the mouse wheel, using the arrow keys, or page up/down have no effect on the page. This can cause information to be cut off from the user.

Version-Release number of selected component (if applicable):
python-django-horizon-9.0.0-5.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install the python-django-horizon package on an OpenStack instance (I used packstack)
2. Log in to the Horizon UI.
3. Navigate to any page or tab.
4. Resize the vertical size of the browser window
5. Observe that no scrollbars are present or appear and there is no means to scroll the content of the page.

Actual results:
No scrollbars or means of scrolling appear on pages that need them.

Expected results:
If a page needs to be scrolled, scroll bars will appear and the user can use the mouse and keyboard to navigate the page.

Additional info:
This was observed against 
  - Google Chrome Version 51.0.2704.106 (64-bit) on Fedora 24
  - Firefox 47.0 on Fedora 24
Another interesting note is that if the browser window is resized to be very short, the top bar (where "Red Hat OpenStack Platform" and the tabs are) DOES get a scroll bar. It appears to be isolated to the content being displayed in the frame beneath it.

Comment 7 errata-xmlrpc 2016-12-14 15:46:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.