This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 135672 - gnome-terminal is a cpu hog
gnome-terminal is a cpu hog
Status: CLOSED DUPLICATE of bug 110154
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-14 07:01 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-10-14 07:01:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
I have gnome-terminal open with several tabs.

I often find that, for programs that produce a lot of output, I have
to switch to another tab because the cpu usage hits 100%.

As a comparison, I ran perl -dDProf script.pl with xboth term and
gnome-germinal.

xterm
real    0m19.997s
user    0m1.304s
sys     0m0.467s

gnome-terminal
real    3m54.364s
user    0m1.301s
sys     0m0.470s

From the results, gnome-terminal seems to use the same amount of cpu
time, but takes more than 10 times longer to run.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Barry K. Nathan 2004-10-18 01:03:11 EDT
I think this is a dupe of 110154
Comment 2 Need Real Name 2004-10-18 02:54:19 EDT

*** This bug has been marked as a duplicate of 110154 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:18 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.