Bug 135677 - Hal doesn't see hotplugged pcmcia/cardbus network cards
Hal doesn't see hotplugged pcmcia/cardbus network cards
Status: CLOSED DUPLICATE of bug 135202
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-10-14 07:59 EDT by Dan Williams
Modified: 2013-03-05 22:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Williams 2004-10-14 07:59:55 EDT
David...  this isn't exactly your problem, but kind of :)

1) Insert card that requires a firmware upload
2) ps -aux shows some stuff:
root      5399  0.0  0.2  3860 1048 ?        S<   07:52   0:00 /bin/sh
/sbin/hotplug net
root      5418  0.0  0.2  6152 1356 ?        S<   07:52   0:00
/bin/bash /sbin/ifup eth1
root      5422  0.0  0.1  2508  764 ?        S<   07:52   0:00 udev net
root      5423  0.0  0.1  2292 1012 ?        S<   07:52   0:00 /bin/sh
/etc/dev.d/net/hotplug.dev net
root      5424  0.0  0.2  2372 1144 ?        S<   07:52   0:00 /bin/sh
/etc/hotplug/net.agent
root      5470  0.0  0.0  2848  240 ?        D<   07:52   0:00 ip link
set dev eth1 up
root      5471  0.0  0.2  2372 1152 ?        S<   07:52   0:00 /bin/sh
/etc/hotplug/net.agent
root      5472  0.0  0.0  2008  248 ?        S<   07:52   0:00 ip -o
link show eth1
root      5473  0.0  0.0  1820  472 ?        S<   07:52   0:00 sed
s/.*link\/[^ ]* \([[:alnum:]:]*\).*/\1/
root      5474  0.0  0.1  2992  520 ?        S<   07:52   0:00 awk {
print toupper($0) }
root      5482  0.0  0.2  3476 1048 ?        S<   07:52   0:00 /bin/sh
/sbin/hotplug firmware
root      5483  0.0  0.1  3460  528 ?        S<   07:52   0:00
/etc/hotplug.d/default/05-wait_for_sysfs.hotplug firmware
root      5484  0.0  0.0  2096  244 pts/1    S    07:52   0:00
/sbin/ip route flush dev eth0

3) Wait for DHCP to fail because the card was ifup-ed by the scripts
4) lshal doesn't see the card
5) restart hald
6) hal sees the card

Other wierd messages in /var/log/messages (prism54 card):
Oct 14 07:54:10 localhost wait_for_sysfs[5714]: error: wait_for_sysfs
needs an update to handle the device '/class/firmware/0000:07:00.0'
properly, please report to <linux-hotplug-devel@lists.sourceforge.net>

Other wierd messages in /var/log/messages (atmel card):
Oct 14 07:47:45 localhost wait_for_sysfs[4288]: error: wait_for_sysfs
needs an update to handle the device '/class/net/eth1' properly,
please report to <linux-hotplug-devel@lists.sourceforge.net>
Oct 14 07:47:51 localhost wait_for_sysfs[4339]: error: wait_for_sysfs
needs an update to handle the device '/class/firmware/pcmcia'
properly, please report to <linux-hotplug-devel@lists.sourceforge.net>


This is with a Netgear WG511 (prism54) and also Belkin F5D6020
(atmel), both need firmware uploads.  The end result is that when you
plug the card in, HAL doesn't know anything about the card, presumably
since the hotplug process fails to run dhclient/ifup and exits.  I
have no idea what the issue here is, the card is certainly not getting
a DHCP address, even though I have everything set up as it should be
in the /etc/sysconfig/network-scripts/ifcfg-eth1 file.

I'll be around today (Thursday) if you guys want to debug.  This
pretty much screws NetworkManager over since it never gets hotplug
events from hal.
Comment 1 David Zeuthen 2004-10-18 17:50:47 EDT
After discussion with Dan: This is fixed with a newer version of udev
- about missing hotplug events and hal coping with that; this is being
fixed in bug 135202 so I'm closing this as a DUP.

*** This bug has been marked as a duplicate of 135202 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:18 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.