Bug 1356795 - [ceph-ansible] : take-over-existing-cluster.yml has syntax error
Summary: [ceph-ansible] : take-over-existing-cluster.yml has syntax error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-ansible
Version: 2
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: 2
Assignee: Christina Meno
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
: 1356794 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-15 04:22 UTC by Rachana Patel
Modified: 2016-08-23 19:56 UTC (History)
9 users (show)

Fixed In Version: ceph-ansible-1.0.5-28.el7scon
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:56:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Rachana Patel 2016-07-15 04:22:27 UTC
Description of problem:
=======================
take-over-existing-cluster.yml has syntax error

Version-Release number of selected component (if applicable):
============================================================
ceph-ansible-1.0.5-27.el7scon)


How reproducible:
=================
always

Steps to Reproduce:
==================
1. Install the ceph-ansible-1.0.5-27.el7scon version of ceph-ansible
ceph-ansible files should be installed at /usr/share/ceph-ansible
2. Copy the sample `group_vars/all.sample`` to ``group_vars/all``
`cp /usr/share/ceph-ansible/group_vars/all.sample /usr/share/ceph-ansible/group_vars/all`
3. Set `generate_fsid: false` in `group_vars/all`
4. Get your current cluster fsid with `ceph fsid` and set `fsid` accordingly in `group_vars/all`
Modify the ansible inventory at /etc/ansible/hosts to include your ceph hosts. 5. Add monitors under a [mons] section, and OSDs under an [osds] section to identify their roles to Ansible.
The default names for these groups are defined in the `group_vars/all` file.
As a reference, refer to step 3 here: https://access.qa.redhat.com/documentation/en/red-hat-ceph-storage/2/installation-guide-for-red-hat-enterprise-linux/#installing_ceph_ansible
6. passwordless ssh from ansible node to all node
7. From the `/usr/share/ceph-ansible` directory run the playbook like so: `ansible-playbook take-over-existing-cluster.yml`


Actual results:
================
[root@magna044 ceph-ansible]# ansible-playbook take-over-existing-cluster.yml 
ERROR: Syntax Error while loading YAML script, take-over-existing-cluster.yml
Note: The error may actually appear before this position: line 35, column 16

        src: "roles/ceph-common/templates/ceph.conf.j2"
        dest: {{ ceph_conf.stdout }}
               ^
We could be wrong, but this one looks like it might be an issue with
missing quotes.  Always quote template expression brackets when they
start a value. For instance:

    with_items:
      - {{ foo }}

Should be written as:

    with_items:
      - "{{ foo }}"


Expected results:


Additional info:

Comment 3 Ken Dreyer (Red Hat) 2016-07-15 13:48:09 UTC
*** Bug 1356794 has been marked as a duplicate of this bug. ***

Comment 7 Rachana Patel 2016-07-22 12:44:17 UTC
verified with ceph-ansible-1.0.5-31.el7scon
worked for both RHEL and ubuntu so moving to Verified

Comment 9 errata-xmlrpc 2016-08-23 19:56:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.