Bug 135694 - FC3T3 hangs on firstboot on Asus P4S800D+Geforce FX5900
FC3T3 hangs on firstboot on Asus P4S800D+Geforce FX5900
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-10-14 10:53 EDT by Philipp Ott
Modified: 2015-01-04 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-28 18:09:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philipp Ott 2004-10-14 10:53:37 EDT
Description of problem: Installation of FC3T3 on an P4+HT, Asus
P4S800D, Geforce FX 5900 machine went fine and after reboot FC3T3 now
hangs shortly after "Installing kernel modules..." Numlock and
Capslock respond but CTRL-C doesnt make boot continue.


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. Reinstalling FC3T3 from CD1 works fine
2. Please remove CD and reboot works fine
3. System hangs again at "Installing kernel modules", 2nd line after
"press I to enter interactive mode"
  
Actual results:


Expected results:


Additional info: appending "nousb nohotplug acpi=off apm=off" resolves
this problem and booting continues.
Comment 1 Philipp Ott 2004-10-15 03:12:58 EDT
I m sorry, the exact message when the stock 541 kernel dies is:
"Initializing hardware". When I add the kernel boot parameters then
booting continues past this line with "Initializing hardware (storage
usb audio...)
Comment 2 Philipp Ott 2004-10-15 03:18:43 EDT
I ran "yum -y update" overnight, with the stock /etc/yum.conf and
now(!) the stock 541 kernel (normal and smp) and the new 610 kernel
(normal and smp) can boot successfully past this "Initializing hardware".

Since the stock kernel 541 now can also boot I think the problem is
not related to the kernel but either kernel modules or some other rpms
dealing with usb/hotplug or so.
Comment 3 Dave Jones 2004-10-27 01:23:23 EDT
could possibly be the recent xorg vs rhgb problem which got fixed.
please reopen if it reoccurs.
Comment 4 Philipp Ott 2004-11-18 03:40:29 EST
I installed FC3 final on the same hardware again (custom packge
selection plus windows samba server and admin tools) and everything
went fine during installation. However, again after reboot FC3 hangs
at "Configuring kernel parameters...." Numlock/Capslock respond and I
can proceed with CTRL-C, however the filesystem stays mounted
read-only and so the booting fails.

Then I booted with the FC3-1 CD in rescue mode and ran "up2date -u -f
kernel kernel-smp" and it worked. up2date installed everything up to
today 2004-11-18 inclusive rhgba, udev and X-Org updates.

Still the problem remains: booting with either kernel as-is and with
either combination of "nousb", "nohotplug", "noprobe", "noapic" etc.
did not resolve the issue: FC3 hangs on my hardware at "Configuring
kernel parameters...".
Comment 5 Olimer Pinzón 2004-11-19 08:33:19 EST
I made the update from FC2 to FC3 and in the first boot I got this 
problem.

It hang on "Configuring kernel parameters"
Comment 6 Philipp Ott 2004-11-20 12:23:24 EST
I used the rescue mode again to enter the system from the FC3-disc1
and ran "rpm -e rhgb" to uninstall it.

Now the installation can boot successfully past "Configuring kernel
parameters...", but now jams at "Starting cups...". I can continue
booting with CTRL-C.

Then X.Org dies horribly trying to access the Geforce FX5900 -
numlock/capslock work, the screen turns black and CTRL-ALT-F1 switches
back to text mode and shows me an error dump of the X server but I
dont get a login prompt anymore.
Comment 7 Carlos Vidal 2005-01-01 13:16:32 EST
The same for me with a ASUS notebook A2G, P4, kernel 2.6.9-1.681_FC3.
It is a clean instalI of FC3. It dies starting cups or sshd in SMP.
Otherwise it works very well in UP.

C. Vidal
carlos@tarkus.se
Comment 8 Dave Jones 2005-07-15 16:26:44 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 9 Philipp Ott 2005-07-16 08:57:47 EDT
I dont have FC3-test on this machine here anymore, so I can't try the new kernel.

I think FC3-release still had the same problem, but booting into resuce system
and running yum -y update brought a new kernel which let me work around the
problem and firstboot worked afterwards.

FC4 works, the release version as well as the FC4 series kernel updates so far.

regards
Comment 10 Dave Jones 2005-07-28 18:09:38 EDT
ok, as the FC3 kernel is the same as the FC4 kernel right now, I'll close this.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.