Bug 1356997 - openstack-core resource does not have interleave=true meta attribute
Summary: openstack-core resource does not have interleave=true meta attribute
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Michele Baldessari
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks: 1290121
TreeView+ depends on / blocked
 
Reported: 2016-07-15 13:03 UTC by Marian Krcmarik
Modified: 2016-08-11 11:36 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-heat-templates-2.0.0-21.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-11 11:36:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1599 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Release Candidate Advisory 2016-08-11 15:25:37 UTC
OpenStack gerrit 342725 None None None 2016-07-15 13:06:21 UTC
Launchpad 1603381 None None None 2016-07-15 13:03:47 UTC

Description Marian Krcmarik 2016-07-15 13:03:48 UTC
Description of problem:
The dummy openThe dummy openstack-core resource was meant to replace keystone so that restarting keystone would not restart the whole cloud. When this resource was introduced the paramter interleave=true was mistakenly left out.stack-core resource was meant to replace keystone so that restarting keystone would not restart the whole cloud. When this resource was introduced the paramter interleave=true was mistakenly left out.
As a side effect of that openstack-core resource is being restarted on all controllers nodes right after one of the controllers nodes comes back online after failover which effectively causing restart of most of the resources and cluster downtime.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Ungracefully reset or fence one of the controller of HA Openstack setup.
2. Wait for the reset node to come back online.

Actual results:
Many resource on all controllers nodes - even though alive controllers nodes which were not reset/fence are being restarted which causing donwtime of Openstack cluster

Expected results:
Resource already running and started on controller nodes should be left in that state and not to be restarted. Only resources on fenced node should be started.

Additional info:

Comment 2 Michele Baldessari 2016-07-25 14:13:10 UTC
Upstream patch has been merged

Comment 4 Leonid Natapov 2016-07-31 10:02:47 UTC
openstack-tripleo-heat-templates-2.0.0-24.el7ost

Clone: openstack-core-clone
  Meta Attrs: interleave=true 
  Resource: openstack-core (class=ocf provider=heartbeat type=Dummy)
   Operations: start interval=0s timeout=20 (openstack-core-start-interval-0s)
               stop interval=0s timeout=20 (openstack-core-stop-interval-0s)
               monitor interval=10 timeout=20 (openstack-core-monitor-interval-10)

Comment 7 errata-xmlrpc 2016-08-11 11:36:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html


Note You need to log in before you can comment on or make changes to this bug.