Bug 1357001 - [rbd-cli] - No error message when tried to delete a meta key that doesn't exists
Summary: [rbd-cli] - No error message when tried to delete a meta key that doesn't exists
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: 4.0
Assignee: Jason Dillaman
QA Contact: Madhavi Kasturi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-15 13:05 UTC by Vasishta
Modified: 2020-01-31 12:45 UTC (History)
6 users (show)

Fixed In Version: ceph-14.2.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:44:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 16990 0 None None None 2016-08-10 19:29:45 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:45:25 UTC

Description Vasishta 2016-07-15 13:05:24 UTC
Description of problem:
While trying to delete image-meta key that doesn't exist, there is no error message getting displayed.


Version-Release number of selected component (if applicable):
ceph version 10.2.2-15.el7cp

How reproducible:
Always

Steps to Reproduce:
1. Try to delete a image-meta key that doesn't exist
( sudo rbd image-meta remove <image-spec> random_key )

# rbd image-meta get test_rbd/test_image06 random_key
failed to get metadata random_key of image : (2) No such file or directory
rbd: getting metadata failed: (2) No such file or directory

# rbd image-meta remove test_rbd/test_image06 random_key

============================================================

Actual results:
command exits without any message.

Expected results:
there should be an error message displayed

Comment 2 Giridhar Ramaraju 2019-08-05 13:10:33 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 3 Giridhar Ramaraju 2019-08-05 13:11:36 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 6 errata-xmlrpc 2020-01-31 12:44:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.