Bug 1357052 - openshift node logs thousands of "couldn't read network stats"
Summary: openshift node logs thousands of "couldn't read network stats"
Keywords:
Status: CLOSED DUPLICATE of bug 1328913
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.2.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
: ---
Assignee: Andy Goldstein
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On:
Blocks: OSOPS_V3
TreeView+ depends on / blocked
 
Reported: 2016-07-15 15:11 UTC by Sten Turpin
Modified: 2016-07-18 12:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-15 15:21:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sten Turpin 2016-07-15 15:11:55 UTC
Description of problem: On a relatively low-usage node, in a 24-hour period, hundreds of thousands of log entries saying that helpers.go couldn't read network stats


Version-Release number of selected component (if applicable): atomic-openshift-node-3.2.0.44-1.git.0.a4463d9.el7.x86_64 (also earlier versions, including 3.0 and 3.1)


How reproducible: always


Steps to Reproduce:
1. Run an openshift node for any period of time
2. Review the logs

Actual results:
journalctl -u atomic-openshift-node --since today | grep -c "couldn't read net
work stats"
289386


Expected results:
This error should be handled better in the code. Logging nearly 300k/day damages the signal:noise ratio in the logs when looking for other issues.

Additional info:
an example of a full log entry is:
Jul 15 15:10:21 ip-172-31-3-96.ec2.internal atomic-openshift-node[7724]: I0715 15:10:21.511529    7724 helpers.go:101] Unable to get network stats from pid 33009: couldn't read network stats: failure opening /proc/33009/net/dev: open /proc/33009/net/dev: no such file or directory

Comment 1 Sten Turpin 2016-07-15 15:21:41 UTC

*** This bug has been marked as a duplicate of bug 1328913 ***


Note You need to log in before you can comment on or make changes to this bug.