Bug 1357065 - When installing with the ISO, repo file is not created
Summary: When installing with the ISO, repo file is not created
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-ansible
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Alfredo Deza
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
: 1357077 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-15 15:46 UTC by Alfredo Deza
Modified: 2016-08-23 19:57 UTC (History)
9 users (show)

Fixed In Version: ceph-ansible-1.0.5-29.el7scon
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:57:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Alfredo Deza 2016-07-15 15:46:07 UTC
Description of problem:
When using the ISO, the ansible includes are using the playbook that installs on redhat which assumes pre-existing repos. The ISO install requires the repo file(s) to be created so the previous step needs to be skipped when the iso installation is used.


How reproducible:
Always

Actual results:
TASK: [ceph.ceph-common | add inktank ceph enterprise repository] *************
skipping: [magna058]

TASK: [ceph.ceph-common | install ceph] ***************************************
skipping: [magna058]

TASK: [ceph.ceph-common | set_fact ceph_stable_rel_pkg="{{ ceph_stable_releases | union([ 'infernalis' ]) }}"
] ***
ok: [magna058]

TASK: [ceph.ceph-common | install distro or red hat storage ceph mon] *********
failed: [magna058] => {"changed": false, "failed": true, "rc": 0, "results": []}
msg: No Package matching 'ceph-mon' found available, installed or updated


Expected results:
Actually create the repo file required to install components

Comment 2 Alfredo Deza 2016-07-15 16:58:11 UTC
*** Bug 1357077 has been marked as a duplicate of this bug. ***

Comment 3 Alfredo Deza 2016-07-15 17:10:32 UTC
Pull request opened: https://github.com/ceph/ceph-ansible/pull/886

Comment 8 Tejas 2016-07-20 13:48:41 UTC
Hi Alfredo,

    I am trying this scenario on version ceph-ansible-1.0.5-31.el7scon.noarch:
Seems to be a key issue. Is this expected?

Logs found at : magna006:/root/bug_1357065/

ASK: [ceph.ceph-common | install red hat storage ceph mon] ******************* 
failed: [magna118] => {"changed": true, "rc": 1, "results": ["Loaded plugins: fastestmirror, langpacks, priorities, product-id, search-\n              : disabled-repos, subscription-manager\nLoading mirror speeds from cached hostfile\n25 packages excluded due to repository priority protections\nResolving Dependencies\n--> Running transaction check\n---> Package ceph-mon.x86_64 1:10.2.2-24.el7cp will be installed\n--> Processing Dependency: ceph-base = 1:10.2.2-24.el7cp for package: 1:ceph-mon-10.2.2-24.el7cp.x86_64\n--> Processing Dependency: python-flask for package: 1:ceph-mon-10.2.2-24.el7cp.x86_64\n--> Processing Dependency: libboost_iostreams-mt.so.1.53.0()(64bit) for package: 1:ceph-mon-10.2.2-24.el7cp.x86_64\n--> Processing Dependency: libboost_random-mt.so.1.53.0()(64bit) for package: 1:ceph-mon-10.2.2-24.el7cp.x86_64\n--> Running transaction check\n---> Package boost-iostreams.x86_64 0:1.53.0-25.el7 will be installed\n---> Package boost-random.x86_64 0:1.53.0-25.el7 will be installed\n---> Package ceph-base.x86_64 1:10.2.2-24.el7cp will be installed\n--> Processing Dependency: ceph-common = 1:10.2.2-24.el7cp for package: 1:ceph-base-10.2.2-24.el7cp.x86_64\n--> Processing Dependency: ceph-selinux = 1:10.2.2-24.el7cp for package: 1:ceph-base-10.2.2-24.el7cp.x86_64\n--> Processing Dependency: libcephfs1 = 1:10.2.2-24.el7cp for package: 1:ceph-base-10.2.2-24.el7cp.x86_64\n--> Processing Dependency: librados2 = 1:10.2.2-24.el7cp for package: 1:ceph-base-10.2.2-24.el7cp.x86_64\n--> Processing Dependency: librbd1 = 1:10.2.2-24.el7cp for package: 1:ceph-base-10.2.2-24.el7cp.x86_64\n--> Processing Dependency: librgw2 = 1:10.2.2-24.el7cp for package: 1:ceph-base-10.2.2-24.el7cp.x86_64\n--> Processing Dependency: libcephfs.so.1()(64bit) for package: 1:ceph-base-10.2.2-24.el7cp.x86_64\n--> Processing Dependency: liblttng-ust.so.0()(64bit) for package: 1:ceph-base-10.2.2-24.el7cp.x86_64\n---> Package python-flask.noarch 1:0.10.1-5.el7 will be installed\n--> Processing Dependency: python-itsdangerous for package: 1:python-flask-0.10.1-5.el7.noarch\n--> Processing Dependency: python-jinja2 for package: 1:python-flask-0.10.1-5.el7.noarch\n--> Processing Dependency: python-werkzeug for package: 1:python-flask-0.10.1-5.el7.noarch\n--> Running transaction check\n---> Package ceph-common.x86_64 1:10.2.2-24.el7cp will be installed\n--> Processing Dependency: python-cephfs = 1:10.2.2-24.el7cp for package: 1:ceph-common-10.2.2-24.el7cp.x86_64\n--> Processing Dependency: python-rados = 1:10.2.2-24.el7cp for package: 1:ceph-common-10.2.2-24.el7cp.x86_64\n--> Processing Dependency: python-rbd = 1:10.2.2-24.el7cp for package: 1:ceph-common-10.2.2-24.el7cp.x86_64\n--> Processing Dependency: gperftools-libs >= 2.4-8.el7 for package: 1:ceph-common-10.2.2-24.el7cp.x86_64\n--> Processing Dependency: libbabeltrace-ctf.so.1()(64bit) for package: 1:ceph-common-10.2.2-24.el7cp.x86_64\n--> Processing Dependency: libbabeltrace.so.1()(64bit) for package: 1:ceph-common-10.2.2-24.el7cp.x86_64\n--> Processing Dependency: libboost_program_options-mt.so.1.53.0()(64bit) for package: 1:ceph-common-10.2.2-24.el7cp.x86_64\n--> Processing Dependency: libboost_regex-mt.so.1.53.0()(64bit) for package: 1:ceph-common-10.2.2-24.el7cp.x86_64\n---> Package ceph-selinux.x86_64 1:10.2.2-24.el7cp will be installed\n---> Package libcephfs1.x86_64 1:10.2.2-24.el7cp will be installed\n---> Package librados2.x86_64 1:0.80.7-3.el7 will be updated\n---> Package librados2.x86_64 1:10.2.2-24.el7cp will be an update\n---> Package librbd1.x86_64 1:0.80.7-3.el7 will be updated\n---> Package librbd1.x86_64 1:10.2.2-24.el7cp will be an update\n---> Package librgw2.x86_64 1:10.2.2-24.el7cp will be installed\n--> Processing Dependency: libcurl >= 7.29.0-32 for package: 1:librgw2-10.2.2-24.el7cp.x86_64\n---> Package lttng-ust.x86_64 0:2.4.1-1.el7cp will be installed\n--> Processing Dependency: liburcu-bp.so.1()(64bit) for package: lttng-ust-2.4.1-1.el7cp.x86_64\n--> Processing Dependency: liburcu-cds.so.1()(64bit) for package: lttng-ust-2.4.1-1.el7cp.x86_64\n---> Package python-itsdangerous.noarch 0:0.23-1.el7 will be installed\n---> Package python-jinja2.noarch 0:2.7.2-2.el7cp will be installed\n--> Processing Dependency: python-babel >= 0.8 for package: python-jinja2-2.7.2-2.el7cp.noarch\n--> Processing Dependency: python-markupsafe for package: python-jinja2-2.7.2-2.el7cp.noarch\n---> Package python-werkzeug.noarch 0:0.9.1-1.el7 will be installed\n--> Running transaction check\n---> Package boost-program-options.x86_64 0:1.53.0-25.el7 will be installed\n---> Package boost-regex.x86_64 0:1.53.0-25.el7 will be installed\n---> Package gperftools-libs.x86_64 0:2.4-7.el7 will be updated\n---> Package gperftools-libs.x86_64 0:2.4-8.el7 will be an update\n---> Package libbabeltrace.x86_64 0:1.2.4-3.el7cp will be installed\n---> Package libcurl.x86_64 0:7.29.0-25.el7 will be updated\n--> Processing Dependency: libcurl = 7.29.0-25.el7 for package: curl-7.29.0-25.el7.x86_64\n---> Package libcurl.x86_64 0:7.29.0-32.el7 will be an update\n---> Package python-babel.noarch 0:0.9.6-8.el7 will be installed\n---> Package python-cephfs.x86_64 1:10.2.2-24.el7cp will be installed\n---> Package python-markupsafe.x86_64 0:0.11-10.el7 will be installed\n---> Package python-rados.x86_64 1:10.2.2-24.el7cp will be installed\n---> Package python-rbd.x86_64 1:10.2.2-24.el7cp will be installed\n---> Package userspace-rcu.x86_64 0:0.7.9-2.el7rhgs will be installed\n--> Running transaction check\n---> Package curl.x86_64 0:7.29.0-25.el7 will be updated\n---> Package curl.x86_64 0:7.29.0-32.el7 will be an update\n--> Finished Dependency Resolution\n\nDependencies Resolved\n\n================================================================================\n Package                Arch    Version               Repository           Size\n================================================================================\nInstalling:\n ceph-mon               x86_64  1:10.2.2-24.el7cp     rh_storage_mon      2.8 M\nInstalling for dependencies:\n boost-iostreams        x86_64  1.53.0-25.el7         rhel-7-server-rpms   60 k\n boost-program-options  x86_64  1.53.0-25.el7         rhel-7-server-rpms  155 k\n boost-random           x86_64  1.53.0-25.el7         rhel-7-server-rpms   38 k\n boost-regex            x86_64  1.53.0-25.el7         rhel-7-server-rpms  295 k\n ceph-base              x86_64  1:10.2.2-24.el7cp     rh_storage_mon      4.2 M\n ceph-common            x86_64  1:10.2.2-24.el7cp     rh_storage_mon       16 M\n ceph-selinux           x86_64  1:10.2.2-24.el7cp     rh_storage_mon       33 k\n libbabeltrace          x86_64  1.2.4-3.el7cp         rh_storage_mon      147 k\n libcephfs1             x86_64  1:10.2.2-24.el7cp     rh_storage_mon      1.9 M\n librgw2                x86_64  1:10.2.2-24.el7cp     rh_storage_mon      2.9 M\n lttng-ust              x86_64  2.4.1-1.el7cp         rh_storage_mon      176 k\n python-babel           noarch  0.9.6-8.el7           rhel-7-server-rpms  1.4 M\n python-cephfs          x86_64  1:10.2.2-24.el7cp     rh_storage_mon       81 k\n python-flask           noarch  1:0.10.1-5.el7        rh_storage_mon      204 k\n python-itsdangerous    noarch  0.23-1.el7            rh_storage_mon       24 k\n python-jinja2          noarch  2.7.2-2.el7cp         rh_storage_mon      516 k\n python-markupsafe      x86_64  0.11-10.el7           rhel-7-server-rpms   25 k\n python-rados           x86_64  1:10.2.2-24.el7cp     rh_storage_mon      158 k\n python-rbd             x86_64  1:10.2.2-24.el7cp     rh_storage_mon       88 k\n python-werkzeug        noarch  0.9.1-1.el7           rh_storage_mon      562 k\n userspace-rcu          x86_64  0.7.9-2.el7rhgs       rh_storage_mon       70 k\nUpdating for dependencies:\n curl                   x86_64  7.29.0-32.el7         rh_storage_mon      265 k\n gperftools-libs        x86_64  2.4-8.el7             rh_storage_mon      272 k\n libcurl                x86_64  7.29.0-32.el7         rh_storage_mon      217 k\n librados2              x86_64  1:10.2.2-24.el7cp     rh_storage_mon      1.9 M\n librbd1                x86_64  1:10.2.2-24.el7cp     rh_storage_mon      2.4 M\n\nTransaction Summary\n================================================================================\nInstall  1 Package  (+21 Dependent packages)\nUpgrade             (  5 Dependent packages)\n\nTotal size: 36 M\nTotal download size: 35 M\nDownloading packages:\nPublic key for ceph-base-10.2.2-24.el7cp.x86_64.rpm is not installed\n--------------------------------------------------------------------------------\nTotal                                              171 MB/s |  35 MB  00:00     \n"]}
msg: warning: /tmp/rh-storage-repo/MON/ceph-base-10.2.2-24.el7cp.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 00da75f2: NOKEY


Public key for userspace-rcu-0.7.9-2.el7rhgs.x86_64.rpm is not installed


FATAL: all hosts have already failed -- aborting

Comment 10 Tejas 2016-07-20 16:54:50 UTC
Thanks Ken.
Moving to Verified.
verfied on version ceph-ansible-1.0.5-31.el7scon.noarch

Comment 12 errata-xmlrpc 2016-08-23 19:57:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.