Bug 1357086 - Memory size for Azure flavor incorrectly displayed in Bytes/KB
Summary: Memory size for Azure flavor incorrectly displayed in Bytes/KB
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.5.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: GA
: 5.5.5
Assignee: Bronagh Sorota
QA Contact: Jeff Teehan
URL:
Whiteboard: azure:ui
: 1357085 (view as bug list)
Depends On: 1317921
Blocks: 1349424
TreeView+ depends on / blocked
 
Reported: 2016-07-15 16:31 UTC by Chris Pelland
Modified: 2016-08-08 18:28 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1317921
Environment:
Last Closed: 2016-07-26 15:37:02 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1488 normal SHIPPED_LIVE CFME 5.5.5 bug fixes and enhancement update 2016-07-26 19:28:27 UTC

Comment 1 Dave Johnson 2016-07-15 16:34:59 UTC
*** Bug 1357085 has been marked as a duplicate of this bug. ***

Comment 2 Dave Johnson 2016-07-15 16:36:56 UTC
Jeff said:

It's the memory size in the flavors list.  There off by 1024.  The actual Azure VM size is correct.  The VM details show the right values.  The bug you reference if from 5.6 and was fixed and verified in 5.6.0.5.  This is probably the clone of that for 5.5.  As of 5.5.5.2, it still shows this under cloud\flavors.  I'm afraid it's still open.

Basic_A0	AzureDJ	1	1	768 Bytes							 	Basic_A1	AzureDJ	1	1	1.8 KB							Basic_A2	AzureDJ	2	2	3.5 KB							Basic_A3	AzureDJ	4	4	7 KB							Basic_A4	AzureDJ	8	8	14 KB							Standard_A0	AzureDJ	1	1	768 Bytes							Standard_A1	AzureDJ	1	1	1.8 KB							Standard_A10	AzureDJ	8	8	56 KB							Standard_A11	AzureDJ	16	16	112 KB							Standard_A2	AzureDJ	2	2	3.5 KB							Standard_A3	AzureDJ	4	4	7 KB							Standard_A4	AzureDJ	8	8	14 KB							Standard_A5	AzureDJ	2	2	14 KB							Standard_A6	AzureDJ	4	4	28 KB							Standard_A7	AzureDJ	8	8	56 KB							Standard_A8	AzureDJ	8	8	56 KB							Standard_A9	AzureDJ	16	16	112 KB							Standard_D1	AzureDJ	1	1	3.5 KB							Standard_D11	AzureDJ	2	2	14 KB							Standard_D11_v2	AzureDJ	2	2	14 KB

Comment 3 Bronagh Sorota 2016-07-19 13:42:03 UTC
Hi Jeff.

I would like to give you a heads up; I was having trouble running a bundle update on my  local 5.5.z branch, this means I could not test this fix myself.

Thanks
Bronagh

Comment 4 CFME Bot 2016-07-19 21:12:51 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=b35b0da84b71c283dcd3187d6f6bd557f31746d9

commit b35b0da84b71c283dcd3187d6f6bd557f31746d9
Author:     Bronagh Sorota <bsorota@redhat.com>
AuthorDate: Mon Apr 25 13:08:00 2016 -0400
Commit:     Bronagh Sorota <bsorota@redhat.com>
CommitDate: Tue Jul 19 09:28:09 2016 -0400

    Flavor memory size needs to be stored in bytes to be
    displayed in the correct unit in the UI
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1357086

 app/models/manageiq/providers/azure/cloud_manager/refresh_parser.rb  | 4 ++--
 spec/models/manageiq/providers/azure/cloud_manager/refresher_spec.rb | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

Comment 6 Jeff Teehan 2016-07-21 21:00:38 UTC
Looks good on 5553, but since that build is DOA, I'll wait until 5554.  Otherwise, it's going to be verified. Nice work.

Comment 7 Jeff Teehan 2016-07-25 15:48:18 UTC
This is fixed and verified using 5.5.5.4

Comment 9 errata-xmlrpc 2016-07-26 15:37:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1488.html

Comment 10 Jeff Teehan 2016-08-08 18:28:44 UTC
Added test case to polarion. RHCF3-11609


Note You need to log in before you can comment on or make changes to this bug.