Bug 135714 - part command requires size, not provided in anaconda-ks.cfg
part command requires size, not provided in anaconda-ks.cfg
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-14 12:47 EDT by david d zuhn
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-21 11:39:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The KS file as created during my manual installation (2.39 KB, text/plain)
2004-10-14 12:49 EDT, david d zuhn
no flags Details

  None (edit)
Description david d zuhn 2004-10-14 12:47:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
The /root/anaconda-ks.cfg as written by the installer during a manual
installation of FC3T3 isn't syntactically correct for use during a
real install.

In particular, the part commands as written do not have a --size
option, just --grow.  Yet, when installing with this file, anaconda
will die because of this missing option.

I can make arguments for two possible ways to resolve this.  

First, write an appropriate --size argument that matches the current
hardware when creating the file during an install.  

Second, when --grow is provided on a command line, --size should be
optional.  In this case, the partition should use all available space.
 When --size is provided with --grow, the argument provides the
minimum size the partition should be.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install FC3t3
2. use created /root/anaconda-ks.cfg for an installation
3. 
    

Actual Results:  Installation dies, due to missing argument.  It's
kind of an ugly death, involving python tracebacks instead of human
readable error messages.

Expected Results:  The same installation I just performed should be
performed again.

Additional info:
Comment 1 david d zuhn 2004-10-14 12:49:18 EDT
Created attachment 105204 [details]
The KS file as created during my manual installation

I used this file as the basis for my automatic installation ks file.  I
uncommented the clearpart, part, volgroup, and logvol commands.
Comment 2 Jeremy Katz 2004-10-17 17:58:06 EDT
Fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.