Bug 135720 - cups prints postscript as text on remote lpd queue
Summary: cups prints postscript as text on remote lpd queue
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cups   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-14 17:13 UTC by Steve Stavropoulos
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 16:22:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Stavropoulos 2004-10-14 17:13:32 UTC
I have a fedora core 2 with cups set up to print via a remote lpd
server (Redhat 7.3 with LPRng-3.8.26). CUPS uses the generic
postscript driver and the remote lpd uses the right driver for the dot
matrix printer (okiibm).
 The problem is that when I print from the cups client, the postscript
is printed as is in the printer. That means that lpd handles it as
text and does a text2ps and then ps2printer_lang. The postscript that
gets printed in the printer clearly says that is created from the cups
daemon. On the other hand, if I try to print from the print server
directly ([user@remote_lpd_server user]$ lpr file) the file prints
normally. Printing from redhat 8 with lprng to the same remote lpd
queue also works correctly.

Version-Release number of selected component:
 At the fully updated (exept the really buggy 2.6.8 kernel) fedora 2
client: cups-1.1.20-11.4  system-config-printer-0.6.115-1 (also tested
with the latest update for fedora 2)

 At the redhat 7.3 server: LPRng-3.8.26

Comment 1 Steve Stavropoulos 2004-11-09 16:22:22 UTC
With the last upgrade for cups (version 1.1.20-11.6) it works fine.
It's a pitty I have already switched to lprng my 64 clients...



Note You need to log in before you can comment on or make changes to this bug.