Bug 135730 - init.d/lock_gulmd should not stop if GFS is mounted
init.d/lock_gulmd should not stop if GFS is mounted
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gfs (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam "mantis" Manthei
GFS Bugs
: FutureFeature
Depends On: 136220
Blocks: 137219
  Show dependency treegraph
 
Reported: 2004-10-14 14:22 EDT by Adam "mantis" Manthei
Modified: 2010-01-11 21:59 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 11:58:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam "mantis" Manthei 2004-10-14 14:22:30 EDT
Description of problem:
The init.d init script should probably not stop if there are resources
running that require it (i.e. GFS and/or GNBD).  Stopping lock_gulmd
on a client mounting GFS can cause orphaned locks to appear in the
lock server (see bug# 129193).  Additional logic that checked to see
if the resource was in use would help prevent the occurance of this bug.

I would like to make the stop operation fail in the event that GFS is
currently mounted on the system.  Operaters running this script
manually will then be informed that the lock_gulmd service is unable
to stop because it is already in use.  

The current stop operation will become a "forcestop" operation so that
this functionality is not lost.

Version-Release number of selected component (if applicable):
GFS-6.0.0-15 and earlier
Comment 1 Adam "mantis" Manthei 2004-10-18 15:31:26 EDT
The cleanest way that I can think to do this requires accessing the
Gulm_Service information of the local lock_gulmd core on the node
calling init.d/lock_gulmd stop.  This information is currently only
available via the SIGUSR1 debugging dumps.  A cleaner resource
requesting method has been requested (bug #136220).
Comment 2 Adam "mantis" Manthei 2004-10-18 19:35:49 EDT
this has been resolved in version 1.1.2.3 of gulm/init.d/lock_gulmd
Comment 3 Tim Powers 2004-12-03 11:58:46 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-659.html

Note You need to log in before you can comment on or make changes to this bug.