Bug 135732 - init.d/lock_gulmd should fail to start if quorum is not established after a specified time
Summary: init.d/lock_gulmd should fail to start if quorum is not established after a s...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: gfs   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Adam "mantis" Manthei
QA Contact: GFS Bugs
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 137219
TreeView+ depends on / blocked
 
Reported: 2004-10-14 18:31 UTC by Adam "mantis" Manthei
Modified: 2010-01-12 02:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 16:58:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:659 normal SHIPPED_LIVE Updated GFS packages 2004-12-03 05:00:00 UTC

Description Adam "mantis" Manthei 2004-10-14 18:31:18 UTC
Description of problem:
The lock_gulmd init.d service script should fail to start if gulm does
not find quorom within a set period of time.  This timeout period
should be configurable so that users can adjust how long to wait
before failing.  Options should include something along the lines of
"wait indefinately", "don't wait" and "wait for X seconds".

This is needed in order to prevent services requiring quorom (such as
mounting GFS) to hang when quorom is not possible.  For example,
without this feature, machines disconnected from an ethernet switch
will not be able to boot since quorom can never be established.

The default timeout will probably be set to 5 minutes.  If after the
timeout period gulm is still not quorate, it will terminate the localy
running lock_gulmd process and report a failure.

Version-Release number of selected component (if applicable):
GFS-6.0.0-15 and earlier

Comment 1 Adam "mantis" Manthei 2004-10-19 17:07:21 UTC
This has been resolved in version 1.1.2.5 of gulm/init.d/lock_gulmd

Comment 2 Tim Powers 2004-12-03 16:58:46 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-659.html



Note You need to log in before you can comment on or make changes to this bug.