Bug 135739 - Fatal server error: no screens found
Summary: Fatal server error: no screens found
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-14 19:26 UTC by Victor Vitug
Modified: 2015-01-04 22:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 20:56:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:550 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 3 Update 4 2004-12-20 05:00:00 UTC

Description Victor Vitug 2004-10-14 19:26:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10.1

Description of problem:
Installed RHAS3 from  CD on a Dell Optiflex GX110 with the on-board
INTEL 810 video adapter.

Initially installed was Kernel 2.4.21-4.EL, XFree86-4.3-35.EL.

     StartX ran fine.

Upgraded the kernel via RHN to 2.4.21-20.EL. with XFree86-4.3-35.EL
still installed.

      Startx failed.

Installed XFree86-4.3-68.EL via RH, rebooted server and ran Kernel
2.4.21.20.EL.

      Startx failed.

Rebooted server and ran Kernel 2.4.21-4.EL and XFreee86-4.3.69.EL.
      
    Startx ran fine.
 
Looks like Kernel 2.4.21-20.EL has a problem with the INTEL 810 Video
Adapter of the Dell Optiplex GX110.





Version-Release number of selected component (if applicable):
Kernel-2.4.21-20EL

How reproducible:
Always

Steps to Reproduce:
1.Install RHAS3 from CD earlier than ASupdate3 - init level 3
2.Upgrade kernel to 2.4.21-20.EL 
3.run startx.
    

Actual Results:  Startx fails 

Expected Results:  startx fires  up the gui

Additional info:

Comment 1 Ernie Petrides 2004-10-14 20:05:18 UTC

*** This bug has been marked as a duplicate of 131907 ***

Comment 2 Ernie Petrides 2004-10-19 03:20:39 UTC
A fix for this problem has just been committed to the RHEL3 U4
patch pool this evening (in kernel version 2.4.21-22.EL).


Comment 3 John Flanagan 2004-12-20 20:56:47 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html



Note You need to log in before you can comment on or make changes to this bug.