Bug 1357427 - virtio driver can't be installed for network automatically in win2012 guest sometimes when convert the guest using virt-v2v by auto
Summary: virtio driver can't be installed for network automatically in win2012 guest s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.3
Hardware: x86_64
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard: V2V
Depends On: 1359086
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-18 08:06 UTC by mxie@redhat.com
Modified: 2017-08-01 22:08 UTC (History)
6 users (show)

Fixed In Version: libguestfs-1.36.1-1.el7
Doc Type: Bug Fix
Doc Text:
Cause: virt-v2v did not always install the virtio driver for the network correctly when convering Windows 2012 guests Consequence: the guests could not have a working network after the conversion Fix: virt-v2v installs the virtio driver correctly when converting Windows 2012 guests Result: network works in converted guests
Clone Of:
Environment:
Last Closed: 2017-08-01 22:08:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
auto-debug-log (1.34 MB, text/plain)
2016-07-18 08:06 UTC, mxie@redhat.com
no flags Details
screenshot (80.43 KB, image/png)
2016-07-18 08:07 UTC, mxie@redhat.com
no flags Details
win7sp1-1 (186.84 KB, image/png)
2016-08-05 04:05 UTC, mxie@redhat.com
no flags Details
win7sp1-2 (74.87 KB, image/png)
2016-08-05 04:06 UTC, mxie@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2023 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2017-08-01 19:32:01 UTC

Description mxie@redhat.com 2016-07-18 08:06:48 UTC
Created attachment 1180946 [details]
auto-debug-log

Description of problem:
virtio driver can't be installed for netwrok automatically in win2012 guest sometimes when convert the guest using virt-v2v by auto


Version-Release number of selected component (if applicable):
virt-v2v-1.32.6-1.el7.x86_64
libguestfs-1.32.6-1.el7.x86_64
libvirt-2.0.0-2.el7.x86_64
qemu-kvm-rhev-2.6.0-13.el7.x86_64


How reproducible:
30%

Steps to Reproduce:
1.Build auto task that convert win2012 guest from vmware to rhev 20 times by virt-v2v
2.About 30% guests would be failed, the reason is that virtio driver is not installed for network so that there is not available ip in win2012 guest,pls refer to details log and screenshot
3.Update network virtio drvier by manual, then the driver could be insuccessfully




Actual results:
As above description

Expected results:
QXL driver can be always installed for network automatically in win2012 guest when convert the guest using virt-v2v by auto

Additional info:
virtio driver could be always installed automatically in win2012 guest when convert the guest using virt-v2v by maunal

Comment 1 mxie@redhat.com 2016-07-18 08:07:35 UTC
Created attachment 1180947 [details]
screenshot

Comment 3 mxie@redhat.com 2016-07-19 05:36:21 UTC
If delete win2012 guest in data domain whose network virtio driver is not installed automatically during virt-v2v auto testing, then import this guest from export domain to data domain again, found that the network virtio driver could be installed automatically at this time, it seems like there is something wrong with importing action during v2v auto testing sometimes, just for your reference,thanks

Comment 4 mxie@redhat.com 2016-08-05 04:05:10 UTC
This bug also could be reproduced on win7sp1 guest sometimes:

Version-Release number of selected component (if applicable):
libguestfs-1.32.6-4.el7.x86_64
virt-v2v-1.32.6-4.el7.x86_64
qemu-kvm-rhev-2.6.0-18.el7.x86_64
libvirt-2.0.0-4.el7.x86_64
virtio-win-1.8.0-5.el7.noarch

Steps to Reproduce:
1.Convert Windows 7 Utimate Service Pack 1 guest to rhev by virt-v2v
# virt-v2v -o rhev -os 10.73.72.75:/home/p2v_export kvm-win7-i386-qcow2 --password-file /tmp/passwd -b ovirtmgmt -n ovirtmgmt 

2.After conversion, import the guest from export domain to data domain at rhevm

3.Power on the guest and open guest's console to check what drivers are installing, found that virtio driver are not installed for disk and network automatically(has a exist bug1356550 to track the problem: qxl is not installed for video automatically) pls refer to screenshot"win7sp1-1"

4.At this time, windows system will remind user to restart the guest for installing driver, but virtio driver still can't be installed for network automatically after restart the guest two times, pls refer to screenshot"win7sp1-2"


5.Could update virtio driver for network by manual,details log pls refer to log:https://libvirt-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/v2v/view/RHEL-7.3/job/v2v-RHEL-7.3-runtest-x86_64-acceptance-ovirt/11/testReport/rhev/convert_vm_to_ovirt/kvm_windows_win7_i386_qcow2_f_NFS/

Comment 5 mxie@redhat.com 2016-08-05 04:05:42 UTC
Created attachment 1187739 [details]
win7sp1-1

Comment 6 mxie@redhat.com 2016-08-05 04:06:10 UTC
Created attachment 1187740 [details]
win7sp1-2

Comment 7 Richard W.M. Jones 2017-02-22 12:59:51 UTC
I'm going to say that we'll just see what the updated windows driver
installation code does in RHEL 7.4, and hope for the best.

Comment 9 mxie@redhat.com 2017-04-01 03:08:02 UTC
Verify the bug with builds:
virt-v2v-1.36.3-1.el7.x86_64
libguestfs-1.36.3-1.el7.x86_64
qemu-kvm-1.5.3-135.el7.x86_64
virtio-win-1.9.0-3.el7.noarch
libvirt-3.1.0-2.el7.x86_64
libguestfs-winsupport-7.2-2.el7.x86_64

Steps:
1.Build auto job:converting win2012 guest from vmware to rhv by virt-v2v 20 times

Result:
All win2012 guests could be converted successfully and checkpoints are passed


So the bug has been fixed, move the bug from ON_QA to VERIFIED

Comment 10 errata-xmlrpc 2017-08-01 22:08:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2023


Note You need to log in before you can comment on or make changes to this bug.