Bug 1357511 - Traceback message seen when ipa is provided with invalid configuration file name
Summary: Traceback message seen when ipa is provided with invalid configuration file name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Abhijeet Kasurde
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-18 12:01 UTC by Abhijeet Kasurde
Modified: 2017-08-01 09:39 UTC (History)
4 users (show)

Fixed In Version: ipa-4.5.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:39:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Abhijeet Kasurde 2016-07-18 12:01:41 UTC
Description of problem:
If User provides invalid string instead of absolute path name of configuration file in '-c' option then ipa command throws traceback. Error message given by command is useful but traceback is too loud.


# ipa -c non_existent_file_name
[2016-07-18T11:59:25Z ipa] <ERROR>: ValueError: config_file must be an absolute path; got u'non_existent_file_name'
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1333, in run
    (options, argv) = api.bootstrap_with_global_options(context='cli')
  File "/usr/lib/python2.7/site-packages/ipalib/plugable.py", line 514, in bootstrap_with_global_options
    self.bootstrap(parser, **overrides)
  File "/usr/lib/python2.7/site-packages/ipalib/plugable.py", line 379, in bootstrap
    self.env._finalize_core(**dict(DEFAULT_CONFIG))
  File "/usr/lib/python2.7/site-packages/ipalib/config.py", line 532, in _finalize_core
    self._merge_from_file(self.conf)
  File "/usr/lib/python2.7/site-packages/ipalib/config.py", line 367, in _merge_from_file
    'config_file must be an absolute path; got %r' % config_file
ValueError: config_file must be an absolute path; got u'non_existent_file_name'
[2016-07-18T11:59:25Z ipa] <ERROR>: an internal error has occurred


Version-Release number of selected component (if applicable):
ipa-server-4.4.0-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. ipa -c non_existent_file_name

Actual results:
Error message with traceback.

Expected results:
Error message is correct but traceback is undesirable to user.

Comment 2 Martin Bašti 🖰 2016-07-22 10:29:37 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6114

Comment 5 Abhijeet Kasurde 2017-05-25 07:43:01 UTC
Verified using IPA server version :: ipa-server-4.5.0-13.el7.x86_64


Steps to verify ::

# ipa -c /tmp/non-existent-file.txt
Usage: ipa [global-options] COMMAND [command-options]

ipa: error: /tmp/non-existent-file.txt: file not found


Marking BZ as verified.

Comment 6 errata-xmlrpc 2017-08-01 09:39:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.