Bug 1357546 - vdsm-hook-vhostmd is not built on 4.0
Summary: vdsm-hook-vhostmd is not built on 4.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 4.0.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.0.2
: ---
Assignee: Anton Marchukov
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks: 1348178
TreeView+ depends on / blocked
 
Reported: 2016-07-18 13:26 UTC by Ryan Barry
Modified: 2016-08-23 20:17 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 20:17:10 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1671 normal SHIPPED_LIVE VDSM 4.0 GA bug fix and enhancement update 2016-09-02 21:32:03 UTC
oVirt gerrit 61082 None None None 2016-07-20 13:01:52 UTC

Description Ryan Barry 2016-07-18 13:26:57 UTC
Description of problem:
vdsm-hook-vhostmd is not part of vdsm builds on 4.0

Version-Release number of selected component (if applicable):
vdsm-4.18.6-1.el7ev

How reproducible:
100%

Steps to Reproduce:
1. Check the build status
2. Check repos for vdsm-hook-vhostmd

Actual results:
vdsm-hook-vhostmd is not built

Expected results:
It should be

Comment 2 Dan Kenigsberg 2016-07-18 13:45:15 UTC
Barak, can you doublecheck that the up-to-date contrib/rhev-build script was used?

Comment 6 Yaniv Bronhaim 2016-07-18 15:13:39 UTC
They used v4.18.4 which doesn't include "7c1ec56 --enable-vhostmd-hook for rhev_build script"

please use version above v4.18.5.1 - its already fixed.

Comment 8 Yaniv Bronhaim 2016-07-19 10:09:02 UTC
Yes I'm sure. I don't know who is dfodor or sbendavi, use only amarchuk builds as he does it formally following vdsm guidelines. please ask him to rebuild from this tag

Comment 9 Yaniv Bronhaim 2016-07-19 11:29:54 UTC
Shlomi, could you double check that in your latest build you have used the most up to date rhev_build script (the one with --enable-vhostmd-hook) ?

Comment 10 Yaniv Bronhaim 2016-07-20 13:01:52 UTC
https://gerrit.ovirt.org/#/c/61082/ fixes the issue

Comment 12 Petr Matyáš 2016-07-22 11:25:32 UTC
Verified on 4.0.2-1

Comment 14 errata-xmlrpc 2016-08-23 20:17:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1671.html


Note You need to log in before you can comment on or make changes to this bug.