Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1357658 - [RFE] Add support for 'DNS3' option in ifcfg-* files
[RFE] Add support for 'DNS3' option in ifcfg-* files
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: initscripts (Show other bugs)
7.4
All Linux
urgent Severity medium
: rc
: ---
Assigned To: David Kaspar [Dee'Kej]
Daniel Rusek
Petr Bokoc
: FutureFeature, Patch, Reopened
Depends On: 1364895
Blocks:
  Show dependency treegraph
 
Reported: 2016-07-18 15:17 EDT by mpathan
Modified: 2018-04-10 14:26 EDT (History)
5 users (show)

See Also:
Fixed In Version: initscripts-9.49.40-2.el7
Doc Type: Enhancement
Doc Text:
`ifcfg-*` files now allow you to specify a third DNS server `ifcfg-*` configuration files now support the "DNS3" option. You can use this option to specify a third Domain Name Server (DNS) address to be used in `/etc/resolv.conf`, instead of the previous maximum of two DNS servers.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 14:24:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Suggestion to fix this issue (2.66 KB, patch)
2016-07-28 08:40 EDT, Carsten Grohmann
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0983 None None None 2018-04-10 14:26 EDT

  None (edit)
Comment 3 mpathan 2016-07-19 11:14:56 EDT
Can we make this bug public ? customer is requesting for public access .

-mpathan
Comment 4 Lukáš Nykrýn 2016-07-20 02:47:12 EDT
(In reply to mpathan from comment #3)
> Can we make this bug public ? customer is requesting for public access .
> 
> -mpathan

I am fine with that.

Also if you don't want any networking daemon running on background I think that NM now has some set&exit mode.
Comment 6 Carsten Grohmann 2016-07-28 08:40 EDT
Created attachment 1185085 [details]
Suggestion to fix this issue
Comment 7 Lukáš Nykrýn 2016-07-28 11:08:37 EDT
As I wrote in comment #1 I am sorry, but we don't accept any new features to initscripts. Please try NetworkManager instead and file any RFE there.
Comment 8 Carsten Grohmann 2016-07-28 11:26:28 EDT
The attached patch is just for reference. Maybe other people have similar issues and the patch could help them.
Comment 10 David Kaspar [Dee'Kej] 2017-10-02 12:21:05 EDT
Hello everybody,

I'm reopening this BZ so it is reconsidered as a valid request for enhancement for initscripts package.

IMHO, even though the 'initscripts/network-scripts' are in "deprecated" state, I think this request is reasonable enough to at least try to implement this change.

However, I can only suggest to add support for 'DNS3' option, because glibc's MAXNS value is still (even in Fedora) set to value *3*, meaning that only 3 nameservers will be actually used for name resolving.

ATM I don't see a valid reason to support DNS4 (or more) in network-scripts, especially when network-scripts are already in "deprecated" state, and they were never meant to be 1:1 equivalent to NetworkManager in the first place. (NetworkManager is suppose to replace and surpass the limitations of network-scripts.)

Best regards,

 -- David --
Comment 11 David Kaspar [Dee'Kej] 2017-10-09 06:23:45 EDT
Pull-request submitted into upstream:
https://github.com/fedora-sysv/initscripts/pull/131
Comment 19 errata-xmlrpc 2018-04-10 14:24:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0983

Note You need to log in before you can comment on or make changes to this bug.