Bug 1357690 - python3 supackage
Summary: python3 supackage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-okaara
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jay Dobies
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3 PY3PATCH-AVAILABLE
TreeView+ depends on / blocked
 
Reported: 2016-07-18 22:07 UTC by dima
Modified: 2017-04-01 17:08 UTC (History)
5 users (show)

Fixed In Version: python-okaara-1.0.37-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-01 17:08:08 UTC
Type: Bug


Attachments (Terms of Use)
0001-python3-subpackage.patch (3.62 KB, application/mbox)
2016-07-18 22:07 UTC, dima
no flags Details
py3 subpackage, add license (4.15 KB, patch)
2016-07-31 18:56 UTC, dima
no flags Details | Diff
Patch to provide Python 3 package (5.86 KB, application/mbox)
2017-03-14 16:18 UTC, Iryna Shcherbina
no flags Details

Description dima 2016-07-18 22:07:53 UTC
Created attachment 1181330 [details]
0001-python3-subpackage.patch

Description of problem:
based on http://fedora.portingdb.xyz/pkg/python-okaara/
implemented patch for add python3 subpackage


Version-Release number of selected component (if applicable):
latest


How reproducible:
apply patch and build rpm

Additional info:
also added patch to github https://github.com/jdob/okaara/pull/13

Comment 1 Jan Kurik 2016-07-26 04:22:33 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 2 Lumír Balhar 2016-07-28 09:54:32 UTC
Hello.

There are some issues in this patch which I mentioned before in previous reviews (missing description in subpackages, release number back to one, global sum seems to be bad, missing changelog ...).

Could you please review your patch and rebase it to the latest version of specfile? Also, link to Koji scratch build would be perfect.

Have a nice day.

Comment 3 dima 2016-07-31 18:56:30 UTC
Created attachment 1186161 [details]
py3 subpackage, add license

update specfile after review

Comment 4 Lumír Balhar 2016-08-01 09:15:43 UTC
Hello.

Thank you for the new patch. Unfortunately, there are still some issues.
- Is better to use global macro for name of module and then %{modname} instead of "okaara" in specfile. Also, you have a bug which breaks build - you should change %{name} to something like %{modname}-%{name}-%{version}-%{rel} in %setup.
- You changed version so release number should be changed back to 1.
- Please improve summary to be more specific.

Also, are you sure that this package supports Python3 in upstream? When I fixed all of specfile issues and tried to build this package, build process ended with a lot of SytaxErrors. Fox example:

running install_scripts
  File "/usr/lib/python3.5/site-packages/okaara/prompt.py", line 150
    except (EOFError, KeyboardInterrupt), e:

Have a nice day.

Comment 5 Lumír Balhar 2016-08-25 09:31:29 UTC
I am currently working on my own PR for python3 compatibility. I'm gonna link it here when it will be prepared and attach patch for specfile. Then we will have to  wait until PR will be merged.

Comment 6 Lumír Balhar 2016-08-26 12:38:39 UTC
Here is my PR for upstream Python 3 compatibility: https://github.com/jdob/okaara/pull/14

I have also prepared a new version of specfile, but it would be better to test it with new release before I attach it here.

Comment 7 Lumír Balhar 2016-10-13 16:25:34 UTC
My PR is merged so now we can wait for a while until maintainer makes new release. If it will take too much time, we can base next version of the package on the latest commit.

Comment 8 Charalampos Stratakis 2017-02-02 18:00:55 UTC
1.0.37 version is released with the improved Python 3 support.

Comment 9 Iryna Shcherbina 2017-02-28 11:53:49 UTC
This is waiting for the GitHub release, as the PyPI tarball does not include the .po files.

Comment 10 Lumír Balhar 2017-03-09 09:28:37 UTC
I've created new issue in upstream: https://github.com/jdob/okaara/issues/17

Comment 11 Iryna Shcherbina 2017-03-14 16:18:01 UTC
Created attachment 1263013 [details]
Patch to provide Python 3 package

Hello,

please find a patch attached to update the package to version 1.0.37 and provide a Python 3 subpackage. I have incorporated the changes from the previous patch and added a switch to build Python 3 subpackage only on Fedora. Please review and apply.

Koji scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=18382009

Comment 12 Fedora Update System 2017-03-15 15:49:49 UTC
python-okaara-1.0.37-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6d64ecb923

Comment 13 Fedora Update System 2017-03-16 00:51:00 UTC
python-okaara-1.0.37-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6d64ecb923

Comment 14 Fedora Update System 2017-04-01 17:08:08 UTC
python-okaara-1.0.37-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.