Bug 135774 - Need to add Kinyarwanda to the locale-list!
Need to add Kinyarwanda to the locale-list!
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-language (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-14 19:20 EDT by Steve Murphy
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 07:02:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Murphy 2004-10-14 19:20:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rw-RW; rv:1.8a3)
Gecko/20040821

Description of problem:


Version-Release number of selected component (if applicable):
redhat-config-language-1.0.4-1

How reproducible:
Always

Steps to Reproduce:
1.not applicable...
2.
3.
    

Actual Results:  no Kinyarwanda choice

Expected Results:  Expect to see Kinyarwanda on the list

Additional info:

It looks like you just need to add:

rw_RW utf8 latarcyrheb-sun16 Kinyarwanda (Rwanda)
rw_RW.UTF-8 utf8 latarcyrheb-sun16 Kinyarwanda (Rwanda)

to the locale-list file in /usr/share/redhat-config-language
... thanks!
Comment 1 Paul Nasrat 2004-10-20 07:02:39 EDT
Unlikely to be fixed for RHEL3. glibc-common doesn't seem to have this
locale in, so there is more work than simply adding that line - fonts,
locale messages, etc need to be considered.  Defer until upstream has
rw_RW support.

If the locale gets added upstream it should be pulled in to future
releases of fedora and RHEL.
Comment 2 Steve Murphy 2004-10-21 16:05:46 EDT
as per your request (pnasrat@redhat.com),
here are a list of bug reports and their entities I've hit so far:

http://sources.redhat.com/bugzilla/show_bug.cgi?id=451
This is the glibc update request. Attached is the localedef input file
for Kinyarwanda/Rwanda.

bugzilla@freedesktop.org  bug #1640  -- request to add rw_RW to the
locale information in that X release

bugs.xfree86.org  bug #1494  -- request to add rw_RW to the locale
info in that release.

bugzilla.gnome.org  bug #155778 asking for specific updates to gdm's
locale info to accomodate Kinyarwanda.

And, hopefully, within a week, a set up upgrades to KDE and GNOME to
supply Kinyarwanda names for languages, and countries, currency, etc.

murf
Comment 4 Steve Murphy 2005-03-01 14:34:41 EST
for 155778, gdm reports "Fixed in CVS head."
for xfee86, status is: 'committed -- thanks'
for glibc, the locale's gone thru a few rounds of updates, and has
been quiescent; I've written today to see if the issue can be closed.
I've entered an issue with x.org, 

https://bugs.freedesktop.org/show_bug.cgi?id=1640

And a few miscellaneous with openoffice.org.

Please, the translation of mozilla is near 50%, and 1.x version of
openOffice is at 95%. Is there anything else to be done to move this
issue to closure?

Many thanks!

Note You need to log in before you can comment on or make changes to this bug.