Bug 1357768 - [Ubuntu] No utilization data available
Summary: [Ubuntu] No utilization data available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: core
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: anmol babu
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: Console-2-GA
TreeView+ depends on / blocked
 
Reported: 2016-07-19 06:23 UTC by Daniel Horák
Modified: 2016-08-23 19:57 UTC (History)
7 users (show)

Fixed In Version: Ubuntu: rhscon-agent_0.0.16-2redhat1xenial, rhscon-core-0.0.37-1.el7scon
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:57:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
Ubuntu - no utilization data available (64.70 KB, image/png)
2016-07-19 06:23 UTC, Daniel Horák
no flags Details
Host dashboard - no CPU and Network utilization data available (100.76 KB, image/png)
2016-08-04 09:35 UTC, Daniel Horák
no flags Details


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 285190 None None None 2016-07-25 19:38:00 UTC
Red Hat Bugzilla 1360889 None None None Never
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Internal Links: 1360889

Description Daniel Horák 2016-07-19 06:23:31 UTC
Created attachment 1181415 [details]
Ubuntu - no utilization data available

Description of problem:
  On cluster created from Ubuntu nodes, there are no Utilization data available on host detail page.

Version-Release number of selected component (if applicable):
  USM server (RHEL 7.2):
    ceph-ansible-1.0.5-28.el7scon.noarch
    ceph-installer-1.0.14-1.el7scon.noarch
    graphite-web-0.9.15-1.el7.noarch
    libcollection-0.6.2-25.el7.x86_64
    rhscon-ceph-0.0.33-1.el7scon.x86_64
    rhscon-core-0.0.34-1.el7scon.x86_64
    rhscon-core-selinux-0.0.34-1.el7scon.noarch
    rhscon-ui-0.0.48-1.el7scon.noarch

  Ceph node (Ubuntu 16.04):
    calamari-server 1.4.6-2redhat1xenial
    ceph-base 10.2.2-17redhat1xenial
    ceph-common 10.2.2-17redhat1xenial
    ceph-mon 10.2.2-17redhat1xenial
    ceph-osd 10.2.2-17redhat1xenial
    collectd-core 5.5.1-1build2
    collectd-utils 5.5.1-1build2
    collectd 5.5.1-1build2
    rhscon-agent 0.0.15-2redhat1xenial

How reproducible:
  100%

Steps to Reproduce:
1. Install and create Ceph cluster from Ubuntu nodes via USM web UI.
2. Go to the Hosts page and click on one specific host.
3. Go to the Clusters page an click on specific cluster.


Actual results:
  On Hosts detail page:
    There are "No data available" in sections Utilization (CPU, Memory, Swap, Storage), Network (Utilization), Performance (Network Latency).
    (See screenshot.)
  On Cluster detail page:
    There are "No data available" in section System Performance (CPU, Memory and Latency)

Expected results:
  All grapsh have correct data.

Additional information:
  Service collectd is running on all nodes and graphite web UI is available on http://<USM_SERVER>:10080/.

Comment 5 Daniel Horák 2016-08-04 09:35:37 UTC
Created attachment 1187417 [details]
Host dashboard - no CPU and Network utilization data available

Comment 6 Daniel Horák 2016-08-04 09:42:17 UTC
There are still missing graphs for CPU and Network utilization on Host Dashboard page as it is visible on attachment 1187417 [details].

If it is different issue covered by another bug, please mark this one as "Depends On" the other Bug.

There are also "No data available" for Swap, which is probably OK, because there is no swap on the machine. (But it will be definitely better to deal somehow better with this situation - no swap, no storage on monitor hosts).

Moving this to ASSIGNED.

Comment 7 Daniel Horák 2016-08-04 09:44:42 UTC
Update for previous comment:

Tested on USM Server (RHEL 7.2):
  rhscon-ceph-0.0.39-1.el7scon.x86_64
  rhscon-core-0.0.39-1.el7scon.x86_64
  rhscon-core-selinux-0.0.39-1.el7scon.noarch
  rhscon-ui-0.0.51-1.el7scon.noarch


Ceph nodes:
  collectd      5.5.1-1build2
  collectd-core 5.5.1-1build2
  rhscon-agent  0.0.16-2redhat1xenial

Comment 10 Nishanth Thomas 2016-08-04 12:34:41 UTC
Per discussion moving this bu to ON_QA

Comment 11 Daniel Horák 2016-08-04 14:24:19 UTC
Mostly all the graphs are working as expected. There are small issues with values close to 0, but this issue is covered by Bug 1360889.

Tested on USM Server (RHEL 7.2):
  rhscon-ceph-0.0.39-1.el7scon.x86_64
  rhscon-core-0.0.39-1.el7scon.x86_64
  rhscon-core-selinux-0.0.39-1.el7scon.noarch
  rhscon-ui-0.0.51-1.el7scon.noarch

Ceph nodes:
  collectd      5.5.1-1build2
  collectd-core 5.5.1-1build2
  rhscon-agent  0.0.16-2redhat1xenial

>> VERIFIED

Comment 13 errata-xmlrpc 2016-08-23 19:57:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.