Bug 1357774 - Need update golang require in etcd-2.3.7-2.el7.src.rpm
Summary: Need update golang require in etcd-2.3.7-2.el7.src.rpm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: etcd
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jan Chaloupka
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 06:41 UTC by Joy Pu
Modified: 2016-09-15 08:30 UTC (History)
0 users

Fixed In Version: etcd-2.3.7-4.el7
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2016-09-15 08:30:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1828 normal SHIPPED_LIVE etcd bug fix update 2016-09-15 11:56:11 UTC

Description Joy Pu 2016-07-19 06:41:42 UTC
Description of problem:

Currently the build require is still >= 1.2.1-3, but the code include some function which is introduced since golang 1.5. If not update it, it will report compile error for it:

898-/usr/lib/golang/pkg/tool/linux_amd64/6g -o $WORK/github.com/coreos/etcd/etcdmain.a -trimpath $WORK -p github.com/coreos/etcd/etcdmain -complete -installsuffix cgo -D _/usr/src/redhat/BUILD/etcd-2.3.7/src/github.com/coreos/etcd/etcdmain -I $WORK -I /usr/src/redhat/BUILD/etcd-2.3.7/pkg/linux_amd64_cgo -pack ./config.go ./const_unix.go ./doc.go ./etcd.go ./help.go ./http.go
899-# github.com/coreos/etcd/etcdmain
900-src/github.com/coreos/etcd/etcdmain/etcd.go:562: undefined: os.LookupEnv
901:error: Bad exit status from /var/tmp/rpm-tmp.t721Nw (%build)

And the buildrequires line from etcd SPECS file:
BuildRequires:  golang >= 1.2.1-3



Version-Release number of selected component (if applicable):
 etcd-2.3.7-2.el7

How reproducible:
100%


Steps to Reproduce:
1. Instaill  etcd-2.3.7-2.el7.src.rpm
2. Try to build etcd with golang 1.4.2 which is default installed in rhel7

Actual results:
Raise error:
etcdmain/etcd.go:562: undefined: os.LookupEnv

Expected results:
Raise correct error with need higher golang.


Additional info:

Comment 1 Jan Chaloupka 2016-07-19 07:08:10 UTC
Thanks Joy.

This is build-time only dependency. No blocker for AH 7.2.6. Will only update the spec file.

Comment 8 errata-xmlrpc 2016-09-15 08:30:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1828.html


Note You need to log in before you can comment on or make changes to this bug.