Bug 1357786 - After update build runPolicy from serial to paralle,the first parallel build in queue will run in serial
Summary: After update build runPolicy from serial to paralle,the first parallel build ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Ben Parees
QA Contact: Wang Haoran
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 07:29 UTC by XiuJuan Wang
Modified: 2017-03-08 18:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The transition between serial and parallel builds was not handled correctly. Consequence: If parallel builds were queued after a running serial build, the first parallel build would also run serially, instead of running all the parallel builds in parallel when the serial build completed. Fix: When the first parallel build is run, also run any other parallel builds in the queue. Result: All parallel builds in the queue start simultaneously when the last serial build finishes.
Clone Of:
Environment:
Last Closed: 2016-09-27 09:40:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description XiuJuan Wang 2016-07-19 07:29:59 UTC
Description of problem:
Trigger one more serial builds, then change builds runPolicy to Parallel, trigger 3 parallel builds.The first parallel build in quene will run in serial after all serial builds complete.

Version-Release number of selected component (if applicable):
openshift v3.3.0.6
kubernetes v1.3.0+57fb9ac

How reproducible:
always

Steps to Reproduce:
1.Trigger one more serial builds.
2.Change bc's runPolicy to Parallel, trigger 3 parallel builds
3.Check builds

Actual results:
After the serial builds complete, the first parallel build will run serially,others keeping "new" status, after the first parallel build complete, the remain two builds will run parallel.

Expected results:
After the serial builds complete, all the parallel builds including the first one should begain to run parallely.


Additional info:

Comment 1 Wang Haoran 2016-07-22 00:59:23 UTC
Hi, Ben, any pr on this bug ? or you don't think it's a bug ?

Comment 2 Ben Parees 2016-07-22 03:14:24 UTC
Sorry, I swear i linked the PR here but i guess not...it was a valid bug, i've fixed it here:
https://github.com/openshift/origin/pull/9969

Comment 3 Wang Haoran 2016-07-22 05:45:49 UTC
(In reply to Ben Parees from comment #2)
> Sorry, I swear i linked the PR here but i guess not...it was a valid bug,
> i've fixed it here:
> https://github.com/openshift/origin/pull/9969

Hi, Ben , considering this scenario, there are 3 serial + 3 parallel + 3 serial + 3 parallel builds in the queue, after the first 3 serial builds completed one by one, there are total 6 parallel builds in the queue , but should we run the 6 builds parallel or just run the following 3 parallel builds, then 3 serial builds, then the last parallel 3 builds ?

Comment 4 Ben Parees 2016-07-22 14:45:14 UTC
the first 3 serial will run serially, then all 6 parallel simultaneously, then the second 3 serial will run serially.

i had some debate about that behavior, but it would be significantly more complicated to do it as 3, 3, 3, 3, and i don't know that running all 6 is wrong. (plus it's not likely to be a real use case for users).

Comment 5 Wang Haoran 2016-07-23 02:15:48 UTC
(In reply to Ben Parees from comment #4)
> the first 3 serial will run serially, then all 6 parallel simultaneously,
> then the second 3 serial will run serially.
> 
> i had some debate about that behavior, but it would be significantly more
> complicated to do it as 3, 3, 3, 3, and i don't know that running all 6 is
> wrong. (plus it's not likely to be a real use case for users).

Ok, if we designed for this , mark this verified.

Comment 7 errata-xmlrpc 2016-09-27 09:40:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.