Bug 135780 - thn-applet-crashes when starting x
thn-applet-crashes when starting x
Status: CLOSED DUPLICATE of bug 135735
Product: Fedora
Classification: Fedora
Component: rhn-applet (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-14 19:54 EDT by Jason
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason 2004-10-14 19:54:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041012
Firefox/0.10.1

Description of problem:
I just patched my system with all of current rawhide updates and the
redhat alert icon is missing.  I just installed the new version of
rhpl-0.148-1.  Could this be the problem?

rhn-applet-gui and tui crash with 

Traceback (most recent call last):
  File "/usr/bin/rhn-applet-gui", line 30, in ?
    import rhn_applet
  File "/usr/share/rhn/rhn_applet/rhn_applet.py", line 36, in ?
    from rhn_applet_model import rhnAppletModelGUI
  File "/usr/share/rhn/rhn_applet/rhn_applet_model.py", line 23, in ?
    from rhn_sources import getSources, changedSources
  File "/usr/share/rhn/rhn_applet/rhn_sources.py", line 8, in ?
    from sourcesConfig import SourcesConfigFile
  File "/usr/share/rhn/up2date_client/sourcesConfig.py", line 17, in ?
    import up2dateUtils
  File "/usr/share/rhn/up2date_client/up2dateUtils.py", line 17, in ?
    import rpmUtils
  File "/usr/lib/python2.3/site-packages/rpmUtils/__init__.py", line
6, in ?
    import oldUtils
  File "/usr/lib/python2.3/site-packages/rpmUtils/oldUtils.py", line
8, in ?
    from i18n import _
ImportError: No module named i18n
[root@pc4331 ~]# rhn-applet-tui
Traceback (most recent call last):
  File "/usr/bin/rhn-applet-tui", line 21, in ?
    from rhn_applet_model import rhnAppletModelTUI
  File "/usr/share/rhn/rhn_applet/rhn_applet_model.py", line 23, in ?
    from rhn_sources import getSources, changedSources
  File "/usr/share/rhn/rhn_applet/rhn_sources.py", line 8, in ?
    from sourcesConfig import SourcesConfigFile
  File "/usr/share/rhn/up2date_client/sourcesConfig.py", line 17, in ?
    import up2dateUtils
  File "/usr/share/rhn/up2date_client/up2dateUtils.py", line 17, in ?
    import rpmUtils
  File "/usr/lib/python2.3/site-packages/rpmUtils/__init__.py", line
6, in ?
    import oldUtils
  File "/usr/lib/python2.3/site-packages/rpmUtils/oldUtils.py", line
8, in ?
    from i18n import _
ImportError: No module named i18n



Version-Release number of selected component (if applicable):
rhn-applet-2.1.11-1

How reproducible:
Always

Steps to Reproduce:
1.  install rhpl-0.148-1
2.
3.
    

Actual Results:  redhat alert icon is missing

Expected Results:  the icon should be there

Additional info:
Comment 1 Michal Jaegermann 2004-10-14 21:53:09 EDT
The bug is not really in rhn-applet.  I installed the last version
on 2004/Sep/23 and the bug showed up only today.  Most likely, as
noted above, with the new version of rhpl ("Library of python code
used by programs in Red Hat Linux").  It is not a platform specific.
Comment 2 Ray Strode [halfline] 2004-10-14 22:01:17 EDT

*** This bug has been marked as a duplicate of 135735 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:19 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.