Bug 135781 - NMWirelessApplet crash locks up Gnome
NMWirelessApplet crash locks up Gnome
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-14 20:07 EDT by julia
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-29 16:47:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description julia 2004-10-14 20:07:38 EDT
Description of problem:

  If you add the Wireless Link Monitor applet (NMWirelessApplet) to
the Gnome bottom Panel twice. And then, a message box pops up saying:
"The Application ""NMWirelessApplet" has quit unexpectedly. You can
inform the developers of what happened to help them fit it. Or you can
restart the application right now.
[Close] [Inform Developers]"
  
  At this point, neither button works, NOR does any other part of the
GnoneWM. I can't change focus to other windows, or even move the Error
window. The keyboard and mouse are still responsive, and I can drop to
a console and then back to X no problem.

  If you restart X, when you log back in, the two applets will crash
again.

Version-Release number of selected component (if applicable):

Gnome 2.8.0 Build Date: 09/29/2004

How reproducible:

 Three times out of three. But the GnomeWM only froze the first time.
Doesn't matter if "NetworkManager" is running or not.

Steps to Reproduce:
1. Install FC3t3, gnome, etc. etc. login as root
1b. The wireless card is eth1, prism54 chipset with firmware in the
right place. But NetworkManager doesn't even need to be running to
reproduce.
2. Right click on an empty spot on the panel; select Add to panel.
3. Scroll down to the bottom and select "Wireless Link Monitor"; "Add"
4. GOTO STEP 2.

Actual results:

  NMWirelessApplet closes unexpectedly.

Expected results:

  It shouldn't crash.

Additional info:

  This should probabily be seperate bugs but...
  Right Clicking on the applet does not bring up the expected menu to
remove the applet, or even move it around on the panel.
Comment 1 Dan Williams 2005-01-29 16:47:35 EST
This is most likely fixed by now in more recent versions of
NetworkManager and NetworkManager-gnome...  Its due to the applet
crashing when exposing the menu, and since GTK grabs an X server lock
when a menu drops down, you can only kill it by going to the console
(Ctl+Alt+1), logging in, and "killall -9 NetworkManagerNotification".

Note You need to log in before you can comment on or make changes to this bug.